New Forum Features Thread

Is anyone else getting odd stuff happening with the placement of buttons and text within buttons? Here’s what I’m seeing (FireFox 48.0.2, 100% page rendering) for the buttons below the post count slider:

27 AM

and below the last post in a thread:

22 AM

The last example, it looks like icon and text for the “Pinned” and “Tracking” are both centred, which results in the text being pushed out of the bottom of the button box, so that’s got to be a CSS issue.

The first one, really not sure what’s up with the placement? They used to be side-by-side.

(@MereAtGBX, @discourse)

Edit to add: It only does this on my desktop running an older version of FF. Everything looks fine on my laptop which is running Firefox 56.0. It doesn’t appear to be a script issue as far as I know?

I’ll check this out, @VaultHunter101!

I’m not seeing anything out of the ordinary in Google Chrome, is anyone else seeing this? And if so, in which browser?

I only skimmed over what you wrote, but have you tried clearing your cache? 9/10 that is the cause with websites not rendering properly.

@MereAtGBX @discourse: A feature request for consideration, please!

There are recurring requests that user signatures be allowed as they were on the old vBulletin system.

I can understand why full-blown signatures could be problematic so, as an alternative, how about one extra line of user-definable text that would appear in the header of each post, directly below the forum name/name/title line? This would mean that the post header was the same height as the user avatar, which isn’t a significant difference and would allow for more informative user post headers. If a user background image could also be added to header (between the avatar and the “in reply to” area), that would be additionally super awesome!


No plans for this, however, there is an “opt-in” signatures plugin that can
be run on enterprise instances.

I strongly recommend not going this route, but at least then the pain is
only shared by those that have ticked the “I want pain” button in their
user profiles.

Out of curiosity, what would that practically look like? I’m assuming it’s an extra area that appears at the bottom of each post, but does it have a fixed size and how big is it? I can see anything more than a couple of text lines being a pain in terms of making the threads take even longer to load/scroll - bad enough on desktop but I imagine very painful on mobile!

Hey @discourse, if you don’t mind I’m having issues trying to format something. I did my best to look on the Discourse forums and on html forums via Google searches, but I can’t seem to figure out how to put a summary/hide details in a html table. Hopefully it’s possible.

Thanks in advance for your time, and sorry if this wasn’t the place to ask this.

Running into a script bug today while trying to edit an existing post. The site script keeps hanging. When I hit the “Debug” option, the Firefox console shows this line:

    css: function( elem, name, extra, styles ) {
        var val, num, hooks,
            origName = jQuery.camelCase( name );

Just going to try this in a different browser…

Edit: Works in latest Firefox without issue, but 48.0.2 seems a little iffy. Not sure what’s going on here.

Edit2: Seem to have been having major latency problems earlier today over some, but not all, connections. That may have been the issue?

Edit3: Nope, same issue on a long post with lots of formatting, but this plain simple one seems to load and edit just fine.

@discourse: liking the new Insert date function, which is really slick, but there’s a slight bug if you use the LLL\T\Z option

May 21, 2018 5:30 AMAmerica: Los Angeles, May 21, 2018 1:30 PMEurope: London

Needs a space between the AM and the user time zone!

1 Like

The new forum absolutely kicks @$$, great job guys

Hey @VaultHunter101, I didn’t know where else to ask this and thought it better here than a PM.

I’ve been trying to figure out how to indent text and haven’t been able to find the code. Then I found something wierd : one of my own threads had indented text :man_facepalming:.
I went into it and found I had used this :


          which results in this.

Is this info actually in the forum somewhere?

1 Like

Not explicitly that I remember, but I will double-check and add it in to the NEW FORUM BASICS thread if necessary; it’s certainly useful information!

Edit: OK, the information was in Sljm’s guide, so I just updated the OP in the Forum Basics thread (and fixed some references to defunct web sites and features).

1 Like

Ah the old & nbsp; thing. I used to use that in an old chatroom to comment blank spaces to confuse the others. Yes, I have no life :slight_smile:

1 Like

Anyone else finding it a pain in the ass tailfeathers to qoute people on mobile with the new menu-thingy that opens up when you swipe left? I don’t know, maybe it’s just on account of my big thumbs flippers, but I’M finding it to be a real pain in the ass tailfeathers…

Yes, I also recently learned how to strike things out, and am enjoying the hell out of using THAT feature, as a way of depicting my mental image slowly becoming more penguin and less human.

1 Like

How very kafkaesque. I wish you all the best Mr. Samsa.
Anyways, to answer : no not having any issues, perhaps opposable thumbs make all the difference.

1 Like

Oh, I see what you’re doing… You’re trying to get me to Google whatever the hell that word means; but you didn’t count on me being lazy now, did you! No, sir!

One of the other forumites helped me a short while after posting, so i’m all good now. Which is good, because this was a serious issue that warranted immediate attention.


Does anyone know how to remove a user from a private message?
I have my list of people in the PM and this button :


All it seems to able to do is add, but not remove.

When you click on the Add or Remove button, you should see white boxes with a grey X in them appear beside the name of each user in the PM thread.

It doesn’t seem to. I thought it might be my browser with all of its blockers but I tried it in another browser and it still has no effect.

It could be blocked depending on your user level? Let me ping @GeekVersusNerd to see if he can offer any insight on this. If there is a problem that needs moderator assistance, send me a PM.

Edit: It looks like this for me:


1 Like