New Forum Feedback Thread


(Best in Funk's collection) #1186

It continues to be an irritant.


(Is this thing on?) #1187

Paging @codinghorror or @JoeKGBX: Is there a way a user can add something to a CODE tag to turn off syntax colouring? I’ve been forced to use CODE blocks as the only way to structure tables within posts. Unfortunately, Discourse then colours this as though it were actual code, which is messy.

Sometimes it also goes bonkers for sites like this with a dark background colour:

+1 -2 +3 -4 +5 -6 +7 -8 +9 -10

That’s a series of positive and negative integers, in case you were wondering!

(Also pinging @nathanielmattock in case he’s seen anything about this elsewhere)

Edit: with four space indenting inside the CODE block:

    +1 -2 +3 -4 +5 -6 +7 -8 +9 -10

(Jeff Atwood) #1188

Indent with four spaces see http://commonmark.org/help


(Is this thing on?) #1189

Thanks! Bookmarked for future reference.


(Is this thing on?) #1190

Hate to be a pain, but this isn’t working consistently. Please see this post for multiple examples. Throughout, I have used [code] ... [/code] blocks for all the tables. Some of these are rendered in the expected fixed width font, and some are not. Some have code colouring, and others do not. Inserting four spaces at the start of each line within a [code] ... [/code] block doesn’t seem to make any difference to the way the block is rendered. (This is all in Firefox 48.0.2 Mac)

Any idea what’s going on here and how to get consistent rendering?

Alternatively, is there any plan to support even very basic wiki-style table mark-up? I really don’t want to resort to replacing every table with a screen shot of an Excel spread sheet…


(Jeff Atwood) #1191

Usually because people don’t put linebreaks before and after. Don’t butt
text right up against the command.


(Is this thing on?) #1192

That’s not what’s happening in this case. Here’s some screen shots I just took so as to focus on the most obvious problem:

What you see in the text editor:

What you see in the actual post:

You’ll notice that the font appears to change part way through the value 0.0483 in the first table row (and yes, I did check that it’s a zero and not a capital o!)

I even tried inserting extra line breaks before and after the code block tags and within the code block tags, but nothing changed at all.

Any other ideas?


(Jeff Atwood) #1193

You might try using triple backticks instead, or 4 space indent.

See https://commonmark.org/help


(Is this thing on?) #1194

If you mean like this:

It doesn’t work - still looks exactly the same. As a little extra back-story, it was actually fine (properly spaced and uniformly in fixed-width serif font) back when I created the post in December 2015. This makes me think that something either in the CSS or in the text processing engine that changed between then and now is choking on this post for some reason.


(Jeff Atwood) #1195

Let’s see:

Item            Weight  Threshold  Probability
Relic (Oz kit)    10      0.0483     4.83%
Class mod         22      0.1546    10.63%
Grenade mod       30      0.2995    14.49%
Shield            45      0.5169    21.74% 
Weapon           100      1.0000    48.31%

Looks like you want 4 space indent, because otherwise it is treating that as actual, literal computer source code – rather than what it is, which is preformatted text. This is screwing up the display.

So indent by 4 spacees. (The toolbar button should do this for you, if you prefer.) Don’t use code semantics unless it’s actual literal source code like “I’m gonna check this into GitHub and then compile it into an executable, yo” source code.


(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #1196

@VaultHunter101 and if you do, dont tell us :wink:


(Not actually Jesus Christ) #1197

Hey @JoeKGBX or @Jeffybug could you perhaps raise the max post count? It has claimed both the How many likes do you have thread and the Random Talk thread :stuck_out_tongue:


Oh Jesus have I posted in the wrong thread… Ok fixed.


(Best in Funk's collection) #1198

Something I’ve been meaning to comment on - after I post sometimes on mobile, it immediately jumps up the page to a much earlier post. This is quite irritating, and it happens regularly for me… I wonder if there’s any way of stopping it?


(Influencer Guy) #1199

Hey there @nathanielmattock! Long time no see. Looks like there’s a HMLDYH 2.0 thread now. As for Random Talk, that one has to have a new thread created every so often, so situation normal.


(Not actually Jesus Christ) #1200

Well the What made you happy today thread just passed 6000 so that might get locked soon.


(Best in Funk's collection) #1201

Far too much happiness on this forum.


(Matrixneo42) #1202

We need to be able to hide the Beta forum for Battleborn.


(Is this thing on?) #1203

After a full year and several game-changing updates, I agree. Any value in the open beta discussions regarding characters and gear has long since disappeared.


(Matrixneo42) #1204

Yea. Even if they have to hide, archive or move it to a subforum area for everyone.


#1205

So, I just tried writing a censored word to describe a certain enemy. Then I did it again in another sentence that was within brackets and noticed that at least for the preview it did not get censored. Sorry for using a mild censored word in my demo below, I’m just not sure if my wording for this is understandable.

this will get cencored: ■■■■■■
(but this will not: asshat)