New PC, strange graphic glitches

Hello

I just got a new rig today ( ASRock B85 Killer, Socket 1150, Intel core i3. Radeon r7 250, 8 gb Ram) and the game runs well with maxed graphics options, except for some rather serious graphic glitches:

  1. When selecting HUD effects to ON, the text and logos on the main menu and option panels become faded , when selecting enhanced HUD effects, the text becomes illegible
  2. This one is rather game breaking

1 , 2 , 3 , 4

Drivers are up to date, other games more demanding than HWR run just fine.

Any help or ideeas as to what is causing this?

on 2, check for anything that puts any sort of overlay or extra effects into the rendering. Afterburner is a frequent culprit.

1 Like

sorry, but what is “afterburner” ?

it’s not something I use, but seems to be the cause of that issue more often than not.

Besides MSI afterburner you shouldn’t use pretty much ANY other overlay software. Overwolf and Evolve woudl also be on that list.

HMM it seems that the issue was " AMD gaming evolved" which i never actually installed , perhaps it came as default with the motherboard drivers. Issue is fixed now, after i disabled the app.

TY for help guys

@radumihaiarkoran AMD Gaming Evolved is a tool that comes with AMD graphics cards, it has nothing to do with the motherboard. It is a tool that is supposed to optimise your game to make it run better, but it really does nothing but downgrade the power of your graphics card and you don’t need it at all. It once tried to suggest to me that I should be playing Skyrim with very low graphical settings, which was nonsense seeing as how I could run the game @ 60fps on 1080p without any problems at medium distances lol.

I won’t argue with you about what the software does, cause i lack expertise, yet disabling the damn thing( aka exit the aplication from tray before starting homeworld) did the trick

I have a new computer too, but the screen resolution is lower than the one I was playing on. Anybody kno how I start with a default 800x600 or similar so I can set the new values correctly? I used to know but have forgotten…

Just expand this post to see the formatting :wink: