No audio after launcher

Hi, as title suggest, I have sound with the game launcher but nothing once game loads (during 2k logo, etc.)

Ive scoured the internet and tried many solutions including all the steps below but nothing worked.

I play on windows 10 Alienware with updated drivers.

Plz help

  1. Verify your game cache
    · Load Steam.
    · From the Library section, right-click on the game and select “Properties” from the menu.
    · Select the “Local files” tab and click the “Verify integrity of game cache” button.
    · Steam will match the local files to the cloud files, and fix any errors it encounters.

*2. Reinstall DirectX *
· In the Steam installation folder of the game you’re having trouble with, there will be typically be a DirectX setup package.
· Example file path: C:\Program Files (x86)\Steam\steamapps\common\Borderlands 2\Binaries\Redist\DirectXRedistCutdown
· Find and run DXSETUP.exe

  1. Additional Software retrieval
    · Navigate to your game’s steam folder – there will typically be another Redist folder.
    · Example file path: C:\Program Files (x86)\Steam\steamapps\common\Borderlands 2\Binaries\Redist
    · In this folder you will find one or more VcRedist installation packages. Run each of them!
    · You should also see a file called dotNETFx40_Client_x86_x64.exe. Run it!
    · During the installation of the VcRedist files, once again you may be prompted to either ‘uninstall’ or ‘repair’ them. Choose ‘repair’ in that case.
    · After you installed all the files, please reboot the computer (mandatory)

Updating your Audio/Video Drivers
Most PC issues can be easily resolved by updating your Audio & Video Drivers. Here’s a few links to help you with that.

Seems to be a problem that crops up intermittently. I’m assuming the reason you included all those instructions is because they are things you’ve already tried.

You can file a support ticket here:

Meanwhile, a few things to check:

  • Did you edit the game config file to suppress cut-scene intros? This can have odd side effects at times.
  • Are you adjusting the audio playback source between launching Steam and launching BL2? There’s a comment about that here
  • Are you using any game streaming or recording software? Maybe try turning that off and launching the game without it. Same with Steam overlay (you should be able to restart it once the game is running?)
  • Are you using Razer Synapse or other configuration software to change keybindings? If so, try closing that, too.

Since I am using Win 8.1, this might or might not apply to your Win 10 system.

If I understand correctly, you can bring up the Launcher.exe and hear the music, but after hitting PLAY,
you no longer hear audio? For instance, you do not hear the music and “2K” spoken when the 2K logo plays, music during the Gearbox splash, and music and “NVIDIA” spoken during the NVIDIA logo even before the Borderlands 2 Title Screen appears?

With Win 8.1, after I hit PLAY in the Launcher window, the Launcher.exe starts Borderlands2.exe. If I run procexp.exe from sysinternalssuite, one of the threads that shows up is a DSOUND.DLL which I guess is a DirectSound feature in DirectX. That thread does not show up when only the Launcher.exe is running. That makes me think that the Launcher.exe is not using the DirectX audio that Borderlands2.exe uses.

Try running DxDiag.exe and see if it finds anything out of the ordinary in any of the Sound tabs. It should display a “No problems found.” in the Notes box.

You can download dxwebsetup to re-install the latest DirectX End-User Runtime. That version may be newer than the one in the Borderlands 2 Steam folder.

1 Like

This might be a little late but I was able to solve mine by fiddling with the recording sources from the Sound control panel. All I did was change the default recording device to the stereo mix.

It was like this:

and then I changed to this:

Hopefully it can help your issue.


I don’t know how or why, but it worked for me too.

1 Like