No fix for the mouse lag issue?


(Cancelegg) #1

I want to get into this game, but this moving the mouse stuff causes awful lag? Really? No I don’t have this problem with any other game. I have a solid rig 5820k, GTX 1080, 16 GB RAM Windows 10 64-bit? 3440 x 1400 100 hz monitor.

Seems like it gets triggered 25-30 minutes into anything I play, campaign or single player vs cpu. Goes from butter smooth, to unplayable when moving the mouse. I tried different mouse, -hardwarecursor , dpi fix in compatibility , toggling all sorts of v-sync. This is kinda unacceptable gearbox. I know others have had this problem and no one has a fix? what did I pay this money for and no one at gearbox has an answer for it? I bought it a while back but didn’t fire it up until a few days ago.

err…umm… help!


(Herbyguitar) #2

Normal…


(El Rizzo) #3

Really ? I haven’t encountered this at all so far and I’ve played sessions way longer than 30min without the mouse lagging so I wouldn’t call it “normal”, however, I also can’t think of a solution or possible cause for this :frowning: .


(Herbyguitar) #4

Well, if it’s not normal then I hope someone knows what it is and can explain it. For me, it only happens in missions.


(El Rizzo) #5

If I were to guess I would assume the 32bit RAM limitation is the culprit and once you hit that wall the game gets laggy as it desperately tries to free up space for new stuff but can’t because the data currently stored is still necessary. Would explain why it occurs after a while as more and more units tend to be in a match the longer it progresses.

That would affect everyone tho and so far I haven’t had this happen to me, so that would contradict my theory somewhat, on the other hand I might just have been lucky and not hit that limitation yet.


(Cancelegg) #6

I’m to going to jinx myself now and tell you the settings I’ve used that MAY have fixed it. In NV control panel for the homeworldrm.exe I set the following: VR pre-rendered frames: 4, v-sync:on (off in game), triple buffering: on, threaded optimization: on, texture filtering: trilinear optimization: on, texture quality: high quality, negative LOD bias clamp, shader cache: off, anisotropic sample optimization: off, maximum pre-rendered frames:1, antialiasing gamma correction: off, antialiasing transparency 8x supersample, single display, optimal performance.

I’ve played through 3 missions and three hours so far with no return of this issue. I don’t know what did it or if it worked permanently. I’ll report back if I see anything different. It’s a good game when it runs right.

oh also, I’ve been saving a lot also, maybe saving early and often helps. Also, also, I’ve not used Afterburner software, like I normally do.


(El Rizzo) #7

Glad to hear that, Afterburner shouldn’t be an issue though as I’m using it myself and regularly bring up my OSD while playing.


(Herbyguitar) #8

It wouldn’t surprise me. Usually when this happens to me I’ve gone a long time without a save, and have a boatload of units on screen. Sometimes the game actually drops to the desktop.


(El Rizzo) #9

Yeah that can happen when the game runs out of memory, used to happen in Skyrim a lot (not the Special Edition) when people tried using High-res texture mods without the appropriate 3rd party mods to circumvent the 32bit limitations :smiley:


(Sastrei) #10

OSD’s and HWRM do not play well together.


(El Rizzo) #11

That used to be the case, it was however fixed with the 2.0 update (or the 2.1, either one of those).