No in-game audio

As the title states, I have no in-game audio whatsoever. On the menus, during cutscenes or gameplay. However, oddly enough, there is audio when the game menu pops up prior to launching the game. I have gone through all simple solutions by adjusting in-game volumes, audio mixers, driver updates, game settings etc. all to no avail. Additionally, when verifying the integrity of the game’s files via Steam I keep getting returned with the message “1 file failed to validate and will be reacquired.” I have no idea what this means or why it’s happening. I am not familiar with Steam and I’ve never encountered this kind of issue before. Is it possible the validation is the culprit? If so, what can I do to fix a failed validation? I’ve already tried reinstalling once, but no changes were experienced.

I do have multiple audio outputs though, e.g., standard speakers (in this case, my headphones) Realtek Digital Output, and my monitor’s output. I was wondering if it’s possible to adjust the default that the game uses. I double checked in my audio devices and my headphones are set as default. But I had a similar issue with Diablo 3 in the past (the game was essentially muted,) despite that my headphones were the default for my PC, they were not for the game itself. Lastly, I am using wired headphones, and I did not unplug or plug them in while loading the game. I only mention the latter because it seems the game experiences issues if you remove or add an audio device while the game loads (from observing other posts online with similar issues.)

EDIT: Fixed… Either my firewall and/or Sonic Studio 3 (an ASUS product, came loaded with my RX580) was causing the issue. Sonic Studio 3 has known conflicts with programs but in my personal experience, only seemed to occur while the program was open. For example, if SS3 was open while I launched Overwatch I would not be able to hear voice chat. Regardless, I uninstalled SS3. However, I also moved some DirectX files around, reinstalled DX, verified file integrity, then loaded Steam/launched Borderlands 2, and my firewall popped up saying “Windows firewall has blocked some features of this program” etc. So, I have the game additional access and it worked afterward. Thanks for the replies everyone. Hope my findings help others with similar issues.

This sounds like the antivirus bug that’s cropped up with both BitDefender and Windows Defender - the AV software interprets the attempt to create or update a needed file as a sign of a problem, and locks the enclosing folder(s). You might want to check the permissions on the folders your BL2 is installed in, and make sure that they aren’t “read only”. If it is an AV issue, you can set the relevant folder(s) to be excluded so that this problem is corrected. Once you can verify files without an error, hopefully things will be resolved.

There’s a bunch of threads/posts in this section with similar issues, so a quick search in with relevant keywords should pull up some instructions if you’re not sure how to proceed.

Hi, thanks for the reply.

I’ve updated the file permissions for Borderlands 2, which were previously set to read-only. I also excluded the necessary folders for Borderlands 2 from my AV (Windows Defender.) I’m still experiencing the same issues with both the file verification and the lack of sound. I only found a couple relevant threads most with no replies or replies with solutions I have already attempted and with no success. I’ve been searching tirelessly on the Internet in general with no luck, with most people getting no responses to the issue and most posts being 2-6 years old now.

Specifically, I have attempted the solutions provided by Muddyone in this thread, where he copy pasted a reply from Gearbox support.

OK, did a little poking around and found this:

If that’s true (I honestly have no idea - not my area of expertise) then it shouldn’t be affecting your audio settings.

As far as audio devices, again not exactly my area of expertise. You can at least check to see if there’s any specific setting for game audio output in one of the configuration files. I’m guessing if it’s there it would be in the WillowEngine.ini file?

If that doesn’t yield any clues, and there’s nothing odd showing up in the system audio control panel/mixer which would account for odd routing or muting, your best bet is probably still to contact support directly:

Just in case one of the PC regulars sees this thread, what OS version are you running?

Thanks for the info. I am running Windows 10 Pro, version 1803. I wouldn’t know where to begin editing config files, so I’ve submitted a ticket to support with all the information I have and the solutions I’ve attempted. Hoping I can get this fixed soon, bought the game on sale and would like to play. I’ll come back to this thread later and post any findings or solutions for others.

I am using Windows 8.1, so this may not apply to you.

Make sure that you close and restart both Borderlands 2 and Steam when you are changing the playback device or recording device. I believe that both the game and Steam will continue to use the device which was the default when they are started and will not recognize that the device was changed while they are running. I have noticed this when my USB microphone stops working in Windows and needs to be unplugged and reinserted. After the mic starts working in Windows again, Steam and Borderlands 2 will still not see it until they are both restarted.

In summary, make sure that the default playback device is correctly set before you start BOTH Steam and Borderlands 2.

Also, I always get the one file failed to validate message every time I verify the integrity, so don’t worry about that.

1 Like