No Such Thing as a Free Launch bugged? (semi-solved)

I play on xbox360 and I am having issues with this quest.

Twice now I get to the point where you are to remove the gyroscope and the console I need to activate is highlighted. I activate it, the console blinks and flashes green check marks. The gyroscope does not become available. The glass it is behind won’t move out of the way.

Anyone else had this go wrong?



So I left the area and worked on another quest to pass some time. When I came back after finishing the other quest, the glass was gone and I was able to grab the gyroscope. Perhaps this still needs to be reported as a bug?

It very definitely is a bug. In fact, it seems to be bugged 100% of the time. (At least it has been for me–glass in the way every single time.) Just exit the game at that point to the menu (which saves) and Continue from there. It’s the quickest way to get to your goal.

I came across that a while back on my Athena NVHM playthrough, but I didn’t think at the time it was a bug. I did what Cobra951 suggested and was able to finish the quest that way.

From my experience it only bugs when you hit buttons too fast (before what’s his face finishes talking)

Save/quit always fixed it for me

Certainly a bug. I Play on Xbox 360 and if you hit X before he finishes talking it will not open. Depending on how fast you click, you may get 3 red X marks when trying to open or 3 green checkmarks. I also was able to save/quit, let him finish speaking and then grab the gyroscope. Seems to me this would be a fairly easy bug to fix. Simply do not allow the option to select until the dialog is completed.

While it may seem like it would be a very easy bug to fix it is probably not the case. Anytime you mess around with the code you have a chance of something else going wrong. As far as everybody else has said though if you save and quit and reload it will work.

For sure regression testing always needs to be completed on any code change. I’ve been a developer myself for over 18 years and am no stranger to fixing one issue only to find out what I thought was going to be a fix caused other issues as well. I cannot speak to any of the actual layout of the methods, classes, events, delegates, threads, etc. It appears that the thread that triggers the event allowing access to the console in this part of the mission appears to happen at the end of the previous stage when you collect the “Flight Data Recorder”, my thought is take that trigger and move it to the thread that plays the dialog in this part of the mission. That would effectively make it impossible to select the console in the first place until the dialog completes and would most likely be the least likely place to cause other issues while fixing this one.

I’m just glad that I will not have to deal with much code at all, I am going into the art aspect of gaming which in its own rights has difficulties as well but with code one small thing somewhere can mess up a lot of stuff. That is why I am always patient for fixes on stuff. I’m sure if everyone got to see just how bad it is there would be far less complaints by people who think that something should be easy to fix, I have a friend who likes to say “fix one code problem and you open up 3 others”

1 Like

Didn’t make a difference last time. I waited patiently for the dialog to end, and it still bugged out. It’s still a perfect failure record for me.

Oh, well that was just from my experience

The bug must love you :smiley:

Should we report it?

I need a virtual can of bug repellent. :smiley:

Only time this happened to me is when I rushed into the computer room and activated the panel. It didn’t happen when I normally defeat all the enemies in the area first.