NVIDIA cards and the Shader Cache in Windows

I’ve been having issues since the Winter Update, in Versus Matches that last over 15 minutes. When all the other players in the server started using their skills at that point in time, my game would begin to stutter terribly, especially when there were bad network conditions between players.

Looking at similar issues in other games (especially games that also have a console release), I began to suspect some problems with caching on my internal storage, and graphics data being swapped between there and my video card’s VRAM.

After making some changes, as far as I can tell, I have eliminated the stutter. If you have a similar issue and would like to try what I did, here are the steps that I took:

Under the “NVIDIA Control Panel”, go to “3D Settings”, and set “Shader Cache” to “Off”. (It is turned “On” by default in the current driver release.) You can change this under the “Global Settings” tab to affect all games, or choose “Battleborn (battleborn.exe)” specifically in the “Program Settings” tab, if you want/need to use the Shader Cache for other games.

Next, open Windows Explorer, and navigate to “%temp%\NVidia Corporation”. If there is a directory there called “NV_Cache”, delete it.

Warning, turning off the NVIDIA Shader Cache may put a little extra stress on your CPU, but I haven’t noticed a significant change. If anything, my game seems to run a little smoother overall, even at the start of a match.

It might also help to set a larger lower and upper boundary for the Windows page file, which can be done by searching “advanced system settings” in the Start Menu, choosing the “Settings…” button in the “Performance” section, choosing the “Advanced” tab, choosing the “Change…” button in the “Virtual memory” section, and setting the page file’s “Custom Size:” option. My pagefile automatically grew to around 8GB after running Battleborn and Steam for a while, so I went with a 8GB - 16GB range.

After these changes were made, I played some long games, and for once, I could actually fight opponents in the last 5-10 minutes, instead of my game being crippled by stuttering every time anyone activated a skill.

I hope this helps someone else. Happy hunting.

EDIT: With the latest October 2017 Geforce drivers, the Nvidia Shader Cache is now causing massive performance drops in Battleborn, as well as some other games. It seems to occur when the Shader Cache nears or reaches its cap, which has been reported to be 256MB.

4 Likes