Patch Required - ..."more recent version of the game"

I am trying to download and play the Claptastic Voyage, but I am unable to. After many attempts of trying to get it to install, suffering from the issues many other people on the forums have complained of, I did finally get it to download properly, but it still says that Part 2 is Downloaded, but it doesn’t say installed.

In addition to this, if I delete the download of Part 2 and re download it, it get an error when trying to install it saying, Patch Required, that it requires a more recent version of the game installed, and to please update my game.

I have downloaded the latest compatibility pack and everything is updated, but no matter what I try, it still will not work.

I saw that same message after I downloaded part 2. I simply quit the game fully then restarted it, and everything worked fine. (Note that I’d downloaded the game update and new compatibility pack already, and had already deleted the old CP.)

I haven’t tried deleting the compatibility packs, but I have deleted and reinstalled the dlc a few times. I can try deleting the old compatibility packs too. The Part 2 to the Claptastic Voyage still shows Downloaded, but it doesn’t show Installed like the others. I have been nervous to try the dlc in the game, concerned that it might break something, or mess up my character.

I guess I can try what you did, ignore the message, and just see if everything works.

Thanks

Here’s what I’m seeing on my system.
Storage > BL:TPS:

  • Comp. pack (637 MB)
  • Claptastic Pt. 1 (2.1 GB)
  • Claptastic Pt. 2 (475 MB)

In-game “Downloadable Content” menu:

  • Claptastic Upgrade pack 2 Not Downloaded (from text appears to be part 2 of 2)
  • Comp. pack Installed
  • Clapastic Voyage & UVH Upgrade pack 2 Installed (part 1 of 2)

I also have the season pass, UVH upgrade pack and Holodome, Shock Drop Slaughter pit, etc.

So I don’t know what’s up with this - the DLC is working for me so far, so I don’t know why the system says the second file (the 475 MB one) isn’t installed. Then again, my highest character is only level 50, so I won’t know for sure if the level 61-70 extension is working.

Paging @Jeffybug or @joekgbx - any idea what’s up with this?

@VaultHunter101- does it seem to be effecting gameplay?

Either way, it seems like redownloading the compat pack could fix. Keep us posted.

It’s not the Comp. Pack, it’s part 2 of the Claptastic Voyage DLC - the smaller one. It’s sitting there on both our drives, but the in-game menu says it’s not downloaded. I personally am not getting any popups or alerts about missing content, just not sure what’s going on. Could you please find out whether that is “expected” behaviour or not?

It’s what VaultHunter101 said exactly. It’s the Part 2 of Claptastic Voyage DLC. It shows downloaded, but not installed, not matter how many times I re-download and reinstall it.

Also, when I completely delete the DLC from my hard drive, and re-download and reinstall it, I receive this error about needing a more recent version of the game to play.

I haven’t noticed any issues with regular gameplay through the standard game areas, but I haven’t went to the Level 13.5, or whatever it’s called, to start the DLC. I was worried it may break something, so I haven’t started the DLC yet.

I don’t know if it matters for this, but I am a Season Pass holder, but I don’t see where that would affect the installation or compatibility of a DLC.

This sounds like it’s possibly compatibility pack related. Is it possible that you’ve accidentally deleted the compat pack when you deleted the DLC? Might double check to make sure.

Otherwise, if you’re not experiencing any problems with gameplay, just keep an eye on it and if anything should arise, let us know.

Sorry it’s taken so long to reply.

I just wanted to update that I definitely did not delete any compatibility packs. I only deleted and reinstalled the Claptrap DLC.

I’ve just ignored the errors, even though they still seem to be there, but it does not appear to be affecting gameplay. I was concerned about it, because I didn’t want to get part the way through the DLC and some sort of corruption, or something really bad happen. I’ll just keep playing and hope for the best.

Everything appears to be working fine at this point. Thanks.

1 Like

I’m having same issue with part one of the dlc!! I didn’t notice til after I played through the whole thing and the achievements didn’t add to my score. They popped but no change in score and I had 51 of 62 before and it still says 51 of 62 after I unlocked 7 more!! Im a season pass owner as well as every single bit of Borderlands games dlc etc. From GOTY BL 1 Loot chest BL 2 also season pass and The Handsome Collection. Per sequel has been the only disappointing thing of all of them. I liked the very short campaign but the dlc has been “Moxxi’s underdome” 3 times in same game( shock drop, holodome,and again at the end of Claptastic) this was the first dlc is was looking forward to after paying $30 for season pass!! I thought it would be like BL 2 dlc and have a few campaign add ons. I loved torgue’s campaign of carnage Tiny Tina dlc was fantastic,Scarlett’s booty was great and Hammer locks was even kinda cool. BL 1 dlc was all GREAT!!! So I expected nothing less from TPS but so far I’m heart broken by this. Especially since the first REAL dlc for it isn’t working right. Honestly all I see at this point is a really big BL 2 add on that we all paid $60 for. PLEASE AT LEAST FIX THIS!! Hoping things get better and sorry bout the rant. Thanks in advance for a patch for this.

Anyone else mentioned problems like I posted here?

This is exactly what I am seeing also, however it does not appear to effect gameplay, if you play co-op, it will NOT save your game progression. IE: all your level increase, gear collected will be there, but the game doesn’t recognize that you ever travelled there and met Jack. It happened to me twice, once when I hosted a game with my son (his game did not save) and once when he hosted (my game did not save) . This could be a result of the Part 2 not downloaded and installed, even if you have done it multiple times, like me.

@Gunzerker2985- passed this along to the team and we’re looking into it.

Thank you joekgbx. Let’s hope we have given you enough to find the problem relatively quickly.

2 Likes

My Dad just ran into this error after buying The Claptastic Voyage DLC and I’ve just spent the last hour trying to troubleshoot it over the phone with him. This is agonizing as I’m in TX and he’s in MI and my efforts are severely hampered by his technical ineptitude. All I hear now is him screaming that he wants a refund since he can’t play the DLC. Please for the love of god, relieve my confinement to the 5 circle of hell that I am in, and tell me how to fix this error.

Steps taken initially:
Compatibility pack was Dl’ed several days ago.
Last night he bought DLC from main menu in the game. (Claptastic Voyage only, not season pass.)
He loaded the game today, and supposedly entered the fast travel station, he can see Level 13 listed, with an asterisk by it, just like the holodome.
If you click it, it tells you you’ve already bought the item do you want to re-dl uvhup2? He says “download again”, and it ends with the error: “You must have a more recent version of the game.”
I have already had him restart the system. Didn’t work.
Had him check that he downloaded both parts.
Cleared the 360’s cache. Restart.Didn’t work.
Deleted any compatibility packs listed on his system for 360 (because having him try and tell me enough to figure out which one was the latest was making me want to scoop my eyes out with a rusty spoon.) Restarted. Didn’t work.
Now when he tries to load the Level 13 it asks if he wants to DL it, he says yes, but it doesn’t to anything. No error, no action, no nothing.

Help.

Did you get him to download BOTH parts of the DLC? There’s the really big one (2.1 GB) and then a second part (~450 MB iirc). When you highlight them in the in-game downloads menu, you’ll see in the info text on the side they say something like “Part 1 of 2” “Part 2 of 2”.

And yes, it sucks trying to do tech support over the phone - you have my sympathy.

Yup, had him double check that too, he’s got both parts of it fully downloaded. Did both of them both times he’s DL’ed it too.

Thanks.