[PC]Borderland 3 Failed To Save My Settings *RESOLVED

when I launch the game everything is fine but at the very menu where it says press any key to continue it says failed to save settings would you like to try again and when I say yes it does the same thing and when I say no the prompt disappears and then its the press any key to continue menu and then when I press a key the prompt comes up again

edit: Fix for me was turning off my windows defender ramson protection and excluding the epic game folders both from program files and program files x86 from my windows defender virus and threat protection settings as well as going into the properties of both epic game folders and unchecking read only mode and going into the permissions and giving them full access (read and write ect.)

Fix

1 Like

A similar problem has occurred with other games. The usual culprit is antivirus/antimalware software setting the relevant folder(s) to read-only mode. You’ll want to exclude the games folder from such things and make sure the folders are set to read-write access. The details depend a little bit on which version of Windows and what AV you may have, so Google is your friend if you are unsure how to do those things.

alright I just did that, ill let you know if it works
appreciate the fast reply

doing this now

I have excluded the files from my windows defender which is my only anti virus and I have made the files read write acess
and it still persist

IIRC the folder hierarchy needs to be excluded, as otherwise sub-folders will get reset. Sorry - the details elude me of the exact fix, but there should be example posts in the BL2 PC Tech Support section here.

The other cause/solution was a mismatch between where the game thought it was saving and where the save files were actually located. This was because Windows had silently remapped user documents to OneDrive using a path shortcut, while the game was expecting the files to be on the main drive.

can you link the forum post?
to tge bl2 tech support section

image this is what I have excluded
I just excluded everything relating to epic games and bl3

Did you reset the permissions on the folders after excluding them from the AV?

no I did that, how do you do that?

1 Like

okn so when I uncheck the read only thing in properties and hit ok when I go back to properties it shows the read only checked again

image

still haven’t fixed it.

FOUND THE FIX. turn off your ramson protection
windows defender had ramson protection. just turn it off and its good

1 Like

How do I do that? I’m having the exact same problem as you.

1 Like

To turn off ransomware protection go here and you may need to unlink OneDrive because it also protects folders go here . Good luck!

None of thats working for me Ransom Protection is off, One drive is unlinked and I even set the folder to not be read only… WTF else do you want from me, Gearbox!?

exclude the epic game folders from your windows defender virus and threat protection

Friend fixed with: Launch Epic Games Store as Admin with compatibility mode with Windows 7 turn off low DPI settings. No idea how this worked but it did for him…

Yea none of this is working for me