Performance on Modern Hardware (speficially GTX750)

Hey,

I was watching a long playthrough by MorninAfterKill and Gothalion on YT and I heard them say something about modern nVidia drivers that mess up the performance of this game.
I got an i7 with 8gb ddr3ram and a gtx750 but even on my 1280*1024 screen I don’t get a solid 60 FPS. I don’t even get a solid 30 fps. Every time I alt+tab and then go back I get epic framedrops for 15 seconds and when a lot is going on I have a lower fps then I expected as well.

I remember getting this game because I couldn’t run anything other then Wolf:ET and this game with my 8600 which was in poor shape. So I expected a little more performance out of this PC.

So is it not supposed to run as smoothly as I thought?
Or could it be drivers-related as MAK suggested and should it run at a solid 60fps on modern hardware?

Thanks in advance,
OttoNL

I would expect modern hardware (sans perhaps bottom dollar dirt cheap stuff), to give triple digit frame rates in most conditions, especially at a resolution like 1280x1024. Now I’m pretty sure some things in Borderlands are pretty poorly optimized, for instance I get severe FPS drops when I am near any elemental proc explosions (from 40+ to sometimes less than 10 if there are a lot of them on-screen and near me). The 15 seconds of epic FPS drops on re-maximizing the game sounds like it’s reloading video assets/rebuilding scene because it dumped them when it was minimized.

1 Like

I suggest messing around in the .ini, IIRC there are some options that like bAllowBetterModulatedShadows=True that make it worse/harder for modern cards to function correctly.

Sounds about right. Can barely push solid 60fps on my GTX 980M. :frowning:
Need one of them highly overclocked dual cores for this old game. Just turn of shadows and enjoy 60fps or lock it to 30fps console style.

Edit: Just checked on my PC. Game barely taxes the 980M, being held back by my i7 4710HQ running at 3,4GHz. Just not fast enough when Borderlands only use 2 cores, one of them being at a constant 100% due to dynamic shadows.
(Measured running around in T-Bone Junction & Tartarus Station)

I highly suggest that you don’t overclock when playing Borderlands. More often than not it’ll crash your PC (or at least some searching on the internet seemed to confirm).
Other games yes, OCing is more than likely good/awesome but for BLands it doesn’t seem to like it much.

[quote=“DEagleson, post:4, topic:231248”]
Edit: Just checked on my PC. Game barely taxes the 980M, being held back by my i7 4710HQ running at 3,4GHz. Just not fast enough when Borderlands only use 2 cores, one of them being at a constant 100% due to dynamic shadows.
[/quote]Yeah, it is much more CPU heavy than GPU heavy which is sad (I have 2 780’s SLI’d together and they’re more or less being wasted in terms of % usage in Afterburner)

Using this method I get over 200fps on my GTX970…

Copy/pasted from the Steam forums:-

You will first need to find the BaseEngine.ini file
Location (Steam Version):
C:\Program Files\Steam\Steamapps\common\borderlands\Engine\Co nfig\BaseEngine.ini
Drive letter may be different

Open BaseEngine.ini using Notepad or WordPad.

!! There are two ways to do this !!

  1. Turn off “Smooth Frame Rate”
  2. Set “Smooth Frame Rate” values to 0
    (I’m assuming Option 2 leaves the feature on but removes the FPS boundaries so it just “smooths” all the frames)

I’m going to show you how to do both.
(not too sure if there is a visual difference)

Option 1:
find the line bSmoothFrameRate
hint: use Ctrl + f to find it quicker
Once you have found it, change the value from True to False.
So it should look like this: bSmoothFrameRate=False
save the file, and start the game.

Option 2:
find the lines MinSmoothedFrameRate and MaxSmoothedFrameRate
Change both values to 0
So it should look like this:
MinSmoothedFrameRate=0
MaxSmoothedFrameRate=0
save the file, and start the game.

Now all you need to do is re-configure your graphics settings, and you’re ready to play Borderlands with unlocked frame rate.

[quote=“P_Anarchist, post:5, topic:231248, full:true”]Yeah, it is much more CPU heavy than GPU heavy which is sad (I have 2 780’s SLI’d together and they’re more or less being wasted in terms of % usage in Afterburner)
[/quote]

Even with all that extra GPU power available we cant even enable proper AA. D: Not worth dealing with the purple outlines on items. Hopefully when Nvidia adds official DSR support on mobile GPUs i can at least downscale from 4k resolution.

Thank you!

You can already do it, sorta (go into .ini and set the res. to the 4k version for your monitor).
100% agree with the purple outline stuff when forcing AA, that’d be awesome if/when they rerelease Borderlands and if it is also rereleased on PC (Better res textures would be so much worth it even if you can sorta fake next gen the resolution/quality of stuff like shadows but being forced with fairly low res textures is heartbreaking.)
TL:DR just for GBX: PLEASE TAKE MY MONEY AND MAKE A REMAKE OF BL1 FOR PC!