Phaselock always active


(Mcore) #1

So I’m playing online, not the host and I used phaselocked as someone transported us. Now phaselocked is always active. I can’t choose new targets and I can’t res. But wreck and elated are always on. Looking forward to getting chain reaction. I’m sure if I respec or restart the issue would be solved but this is pretty interesting. Has this happened to anyone else here?


(I’m Nat and just a Number.) #2

happened to me as well. it might be due to lag. i tried to recreate it since it might be useful for raid bosses due to phaselock skills always active, but couldn’t.


(Yeti, deconstructed in 3 courses.) #3

Just to be different, I had it happen to me while I was playing solo on one of the early peak runs, maybe the OP2->OP3. I had thoughtlocked something, then it died, then I had permaWreck/Chain Reaction/Elated. I got whacked by a Rabid skag and when I respawned everything was back to normal. I’ve never seen it happen since. I figured I had just done a quick flyover through the Twilight Peak.


(Mcore) #4

I’m assuming it only works if your not hosting. Now I’m going to phaselock something everytime I transport in someone else game lol.