PhysX problems on Windows 10

Hi there,

After recently installing Windows 10, I decided today to play some Pre Sequel. Unfortunately, I seem to be having issues with PhysX on this new OS install.

I noticed that I was getting bad frame rate drops in the game, where I NEVER used to on my previous Windows 7 install. I looked at the in game settings and noticed the the PhysX option was greyed out and could not be changed.

I went to the Nvidia Control Panel (latest driver 355.82) and checked the PhysX settings. The setting was on “Auto Select”, so I tried forcing it onto my GPU (Nvidia 980Ti) but this made no difference. As an experiment, I also tried forcing PhysX onto the CPU but this made no difference either…PhysX was still greyed out in game.

I should mention that the PhysX setting IS available when you first run the game through the Settings tab on the Splash Screen and changing the setting does reflect in the “In Game” value but as soon as you are running the game, the in PhysX setting becomes unavailable…it is visible, but greyed out.

Along with this new phenomenon, the game performance has also been hit severely in places. I seem to be getting bad frame rate drops, even though I have clocked up dozens of hours in this game on my previous Windows 7 install and it was butter smooth. I am ALSO experiencing EXACTLY the same problems in Borderlands 2…identical issues where before there were none.

So, I am having strange problems with PhysX in the Pre Sequel AND Borderlands 2 (cannot change the in game PhysX settings) and I’m getting severe frame rate drops in certain areas on BOTH games.

i really need to start a thread for this issue
so, device manager, display adapter.
Right click on it and select "Update Driver Software…
Select “Browse my computer for driver software”
Select “Let me pick from a list of device drivers on my computer”

This will allow you to select the driver you want to use from a list of the compatible drivers.
https://dl.dropboxusercontent.com/u/41629841/Photos/Sound%20Problem/Driver%205.PNG
Number 1 is the correct driver that should be installed by what you download from nvidia.
Number 2 is the driver that gets obtained from Windows Update.
Number 3 is a generic driver that windows uses for compatibility with most graphics cards without the need for third party drivers.
select the correct driver, install, restart
if it doesnt work, back to device manager, display, delete everything there but the basic, restart, redownload the correct driver from nvidia, install it, and restart again.

Hey there,
many thanks for your reply. I had a look at my display adapter in Device manager as you suggested. however, the only entries I have for available drivers on my system are:

image

There are no Nvidia drivers listed as being installed by Windows update (I checked my Windows “Installed Updates”). Before installing this driver , I removed the old drivers with Guru3D’s “Display Driver Uninstaller”. This tool is supposed to clean all traces of Nvidia drivers off your system before proceeding with a new driver installation.

This problem existed before doing a clean driver install and also after it, so re-installing the driver didn’t seem to help.

This is how my Windows 10 settings are regarding the OS installing drivers:
image

good that you have that set, most don’t.
ok, try device manager, display, and delete the nvidia adapter, and restart, then do a clean install with the nvidia installer, so that you essentially delete it twice. then restart again.
If still crappy, try running bl in win 7 compatibility mode. or just rolling back to 7, as 10 is basically a huge steaming pile of spyware.
http://www.nvidia.com/download/driverResults.aspx/90500/en-us

Hey there,
well, I figured out what the problem was. I realized I had SweetFX 1.5 installed on both games. That was working fine on Windows 7 but not on Windows 10. I removed the files from the games directory and bingo…PhysX is available in game settings.
Both games also seem to be running a lot better. I get the feeling that PhysX on Win 10 is causing heavier frame rate drops than it was in Windows 7 but I can live with it for now.

Thanks for your help.

yeah, woulda helped if i’d known you had reshaders installed.

Yes indeed…my apologies. I didn’t know myself until I went to switch compatibility mode on the executable.