Potential Game Crash Solutions (For your pleasure)

So I figured I might as well compile some of the fixes I’ve found for the crashing issues I see often. Now, I see a lot of people recommending elaborate solutions like “reinstall your drivers” or “reinstall windows.” As some of us know, that ■■■■ don’t work. Neither does rolling back your graphics driver (probably I don’t know, who cares.) Also DX12 is busted to ■■■■, if it works for you, good, but it likely won’t. But may if you do this https://www.dsogaming.com/news/here-is-how-you-can-completely-fix-the-annoying-dx12-stutters-even-with-ray-tracing-in-control/. Obviously substitute references to Control with Borderlands 3.

So! Here are some fixes. If absolutely none work, go for reinstalling your drivers or windows if you’re that desperate I suppose. (Also seriously, update your drivers first, Driver Booster is free and easy.)

Also make sure you’re running the Epic Games Launcher in administrator mode, sidesteps a lot of issues. Namely that LS-0013 or whatever one.

Also also, Windows has been breaking things left and right with their wonderful “fixes.” It’s frustrating, and saddening but there’s nothing we can really do about that unfortunately.

For:
182f0c7b Borderlands3 0x0000000040000000 + 182e2bb7 KERNEL32 0x000000003ea70000 + 17bd4 ntdll 0x00000000401e0000 + 6cee1

or “pak decompression failed.”

I went to E:\Program Files (x86)\Epic Games\DirectXRedist in the epic games folder (check whatever drive you have it on.) Unpacked all of those zipped files into that folder and now I’m able to play :smiley:

Verifying game cache also seems to do the trick. I’ve needed to verify after each computer restart, likely you will too.

I also capped my fps to 120 (using a 144 hz monitor) and turned on vsync but I’m sure those are unrelated but figured I should mention just in case.


Either GeForce Experience of Razer Synapse causes 100% gpu memory usage (memory leak.) Close em. I don’t care to figure out which one someone else can.


https://www.geeksinphoenix.com/blog/post/2016/05/10/how-to-manage-windows-10-virtual-memory.aspx

Harmless, and may solve issues. I have no sure idea, I tried multiple solutions at once then ran the game. I’m a programmer, not a QA tester, and I’m definitely not getting paid for this.


Turning off cloud saves seems to work for some people, and also will protect you from corrupted saves too so might as well just flip that switch.


Go into NVIDIA control panel, go to manage 3d settings, find “Power Management Mode”, change it to anything but that default.


Run a command prompt as admin, type in sfc /scannow. If windows says you’re in the clear, good, if not you likely need a restart and that may clear up some issues.

Today I learned that SFC has been broken since July and was only fixed this Tuesday in a Windows update that also broke other things that have to do with Defender. May work now.


DISM /Online /Cleanup-Image /CheckHealth should help with any disk issues. Again, run in an admin command prompt.

Follow that if it says your pc is forked. I’m not gonna retype it you lazy lizard.


Feel free to post more fixes. Good luck!

1 Like

I’m not sure if it’s just a performance thing, but I’m only lagging hard on certain parts, either too much colour or too much going on

Having the exact same problem here. I’m getting the pak decompression failed error almost every time. Occasionally i can go an hour or two with no crashes, but often it is every 5 to 10 minutes.

I’m also on a similar build. Same mobo, 2080, and an 9900K.

could it be an antivirus thingy ? some kind of real time protection ? I heard some people had to add bl3.exe to their exception list.

I’m not even running an anti-virus unless you count Windows Defender

Just tried turning off any problematic bits of windows defender, still same crash. Best I can tell its some issue with a windows driver so I’m not sure how to fix that other than wait for windows to do it at this rate. I can’t even find that many others with this issue.

Since we have the same mobo, did you try updating your BIOS? I’ve heard some people suggest that, but I’ve heard that doesn’t work for a lot of people.

Tried that as well, didn’t work. Although it’s probably good to have gotten it done anyways.

Going to try and roll back to the May 2019 update of windows 10. Will report back here if it changes anything. o7

I may have finally ■■■■■■■ fixed it. @DiabolicalToast

I went to E:\Program Files (x86)\Epic Games\DirectXRedist in the epic games folder (check whatever drive you have it on.) Unpacked all of those zipped files into that folder and now I’m able to play :smiley:

I also capped my fps to 120 (using a 144 hz monitor) and turned on vsync but I’m sure those are unrelated but figured I should mention just in case. I hope it works for y’all, and spread the word!!!

1 Like

Is this what the DirectXRedist folder looked like before you unpacked the files? I don’t see any zipped files. It looks like I can open up the cab files and extract the contents. Is that what you did?

Yep! Sorry for the late response, I just unpacked whatever was in those .cab files. I assumed they were zip files because they had the winrar logo next to them. Sorry

1 Like

Ok cool. I’ll give that a try. I capped my fps at 60 last night and didn’t get any crashes, but I didn’t play for long. Hopefully this is the solution.

This is the only thing that worked for me. Been playing for hours now with no issue. Hopefully more people find this. THANK YOU!

1 Like

Thank you so much! I was crashing every hour before this!

I played for about 4.5 hours last night after extracting those files without a single crash. Going to bump my fps cap back up to 144 tonight. Looks like this might be the fix!

Did not work for me. Still crashing.

Is this still working for you? I’m about to try it after everything else has failed. I also have the same mobo and gpu as you.

Bumped my FPS back up, and started crashing again… This is unfortunate.

I’m back to crashing even with fps capped at 60. It was fun while it lasted…