Reviving Gear Calc on Flashpoint

Seems like they could only reboot flash apps and movies that were still running but Im not sure.

1 Like

If we just could lay our hands on a gearcalc itself maybe we could revive it.

You can still get a swf file or use downthemall to dump files but one needs to change lines 838 and 839 from false to true so that the prog stops checking if its online or not.

https://www.reddit.com/r/Borderlands/comments/jeu26t/gearcalc_preservation_anybody_know_flash_well/

Not sure if this works tho, I havent had the chance to try this.

1 Like

I got this working and submitted it to Flashpoint, it should be included in a future release.

In the meanwhile to get it going manually:

  1. Download Flashpoint (Infinity or Core is fine, Ultimate seems excessive for this.)
  2. Extract it wherever.
  3. Download GearCalc. (Don’t extract.)
  4. Run the “Start Flashpoint” shortcut located wherever from step 2.
  5. If you’re running the Infinity version go to Config and check the box by Enable Editing.
  6. Under Curate click “Load Archive” and select the Gear_Calculator.7z you saved in step 3.
  7. At the bottom of the resulting page click “Run” (or alternatively “Import” to access it from the Games section. You may need to restart Flashpoint for this.)
  8. Enjoy!
3 Likes

Awesome, will try!

Great, thank you!
It’s working!

1 Like

I don’t know why but when I run the gearcalc give me an error #2046

1 Like

same for me

Same here :o(

I don’t know why you all getting errors

I’m running fine on Win10

Does anyone know how to fix the “Error #2046”?

Ok, so I figured out how to fix error 2046 so all of you who are getting the error do this.

  1. Install Flashpoint Core don’t use anything other than core, not even Infinity

  2. Open Your Flashpoint Core 10 folder, Know goto >Utilities>cURLsDownloader

  3. Open the cURLsDownloader file now copy this link > “http://gearcalc.50webs.com/release/GearCalcApp.swf”(Without the ") and press Ctrl+V and press enter wait until you see 3 options after you see them type 1 and press enter and wait until it says “Finished Fetching” now press enter again you will be taken to a folder that has a folder called gearcalc

  4. Without closing the folder you were taken to open the “Start Flashpoint” Shortcut then go to Curate and click on “New Curation” on your new curation go down and click on “Open Folder” you will see a folder names contents in that folder open it now switch back to the other Folder and copy the folder that has the word Gear/Gearcalc in it and paste it into the other folder (contents folder)(The link to the content folder is Flashpoint Core 10\Utilities\cURLsDownloader\Downloads), After doing this close Flashpoint and open it again goto curate tab again, you should see a curation with a flash icon on the left click on it now go down you will see “Content Link” or something that has content in it next to it you will see the word Gearcalc if you don’t it’s probably because you are looking at the wrong “Content” now copy the link in the content tab (As i said it should contain a link or something that has the word gearcalc or gear) go up and click on launch command now type “http://”(Without the quotes) and then paste the content you copied (Ctrl+V) Now if you go a bit up you should see “Application Path” click on it and select “BasiliskBrowser”

  5. Go down and click on Run with mad4fp it should open a browser page which is the gearcalc.
    P.S
    You will still face many action script errors while running it but always press dismiss all

I know this is hard to understand for some ppl so I’m trying my best I also messed up the Steps part cause step 5(I fixed the steps up a bit) is hella long if anyone wants to simplify this please do

3 Likes

Thank you G_Grim,

I got it to work on my PC your way, however it didn’t work on my laptop with this method.

I got it to work by unzipping the GearCalc file mentioned by pcrov and placing it’s content (2ea45…) into the Flashpoint directory as followed:

Flashpoint Core 10>Curations>Working

It is already configured so you don’t need to change anything. I ran it with mad4fp and got it to work.

1 Like

Glad to see it worked!, Question did you get it to work on your laptop by unzipping the GearCalc mentioned by @pcrov, or did you do it on your pc?
Anyways the unzipped GearCalc @pcrov can be used since it is the same SWF file I said to download from CuURLsDownloader P.S did you remove the quotes from the link while downloading it on CuURlDownloader?

Neither one worked for me. Both of them end up complaining about not having a valid signature.

Any ideas?

This happened to me as well I’m not sure this works but you could’ve possibly downloaded the SWF file from another link? so try downloading with CURLsdownloader if you downloaded with that and it doesn’t work try clearing the cache of basilisk browser(I’ll provide the details later) try doing it on another device(if you have one) and see if it works or if you have discord the mods in the flashpoint community might be able to help you (please make sure to ask in the curator’s lounge channel). I also remember having this problem when I tried to run the calc with the SWF file provided by @pcrov. I don’t quite remember what other times I had this problem but I definitely had this when I tried using the instructions from @pcrov’s but instead of clicking run i clicked run with mad4fp

Thanks Grim,

The only thing stopping me from using this is when I click “Run.” When I click this, nothing actually happens, not even an option to run with “mad4fp” or any error.

There aren’t any unhandled exceptions either, any idea on what I need to do?

That’s most likely because you are running an older version of flashpoint core or you aren’t running the core version I haven’t played borderlands in a while neither have I been using flashpoint so I’m not really up to date but I believe the latest version of flashpoint is 10
Edit: run with mad4fp was added in 8.2 so it’s probably you are using an older version if it’s not that try the 2 methods in this link also make sure to write http instead of https when running mad4fp

also if anyone is having any problems with doing this try and follow this video until 3:40 the rest of the stuff after that is not needed, also make sure to run in mad4fp

I’m using Flashpoint 10 currently, I tried both methods through the link in your reply but nothing is happening. I even followed the video, still no success unfortunately.

Try reinstalling Flashpoint, if it doesn’t work try this
Follow these steps to activate MAD4FP:

  1. Go to the Config tab on the launcher, scroll to Advanced, and on Server switch to MAD4FP Mode .
  • Keep in mind that the defaults for Core and Ultimate are Apache Webserver and for Infinity, it’s PHP Router.
  • Note the regular functions of Flashpoint Infinity (playing games regularly) do not work while MAD4FP is enabled.
  1. Press the Save and Restart button at the bottom of the Config page.
  2. After Flashpoint restarts, go to the Curate tab
  3. Enter the title and platform of the game, and any other metadata you can find. For the Launch Command, paste the URL of the page where the game is located. If you plan to use the Flash projector, paste the direct link to the game SWF instead.
  • Note that if the original URL uses HTTPS, you will need to replace https with http .
  1. Once all of the assets seem to have loaded, navigate to Flashpoint’s Legacy\htdocs\content folder, copy all the files and folders to your curation’s content folder, retaining the same structure. Refer to the Curation Tutorial.
  • For Flashpoint 8.2 Infinity or below, go to Server\htdocs folder and sort the contents by Date Modified. Determine which files and folders belong to the game you just downloaded.
  1. After getting all assets, switch back the server from MAD4FP Mode, Save and Restart, and run the curation again to test no assets are missing. If they are, copy 404 URLs to download them or run the game with MAD4FP again