RODOH has cometh!

I don’t really need lightning and shading. I’m really interested in the mesh and textures.

I would love to PM you but I can’t find how to do it …

PS thx @Mikali for this soft, I didn’t knew it.

How do we get “= -log” to give us a log to review? I tried “= -log = c:\LOG.TXT” but it was ignored

Eh? I don’t think that really works… -log just means ‘do logging’ - as does -dump. 99% of the time that info isn’t useful to anyone but me.

drat, I was hoping the get the output. It lists all the HODs that it fails to parse, no helpful errors but it would be a to-do list for me

I took RODOH.exe - I make out oldHOD to newHOD, and that’s what happened
The model is efficient and works but it is distorted.

I looked her in oldHOD to CFHodEd-HWRM-v4.1.1.0 and was all good

Why RODOH.exe tore holes in the model?

RODOH has some issues with meshes that I haven’t completely ironed out yet - the Max DAE parser also likes to explode for no reason…

Where’d you get that mesh from? Send me the HOD and I can use that for some of my debugging…

1 Like

Give your e-mail so I could send a file

dave.eaton@gearboxsoftware.com - shouldn’t be hard to guess :wink: Thank you!!!

I sent you a file, please figure it out what it was :wink:

Did you make it through the pile of HODs that you collected for RODOH last time @bitvenom?

Yes and No - in some cases the output file was just screwed and made Max angry. I’ve been focused on everything else for obvious reasons :slight_smile: I’ll get back into it shortly. For now, I am just bracing for issues people have with HODOR - I haven’t heard a Peep since it was pushed this afternoon… weird.

2 Likes

I’ve been busy tossing all our new BSG meshes in. :wink:

I like the “i haven’t crashed yet, honest” display of x’s. :smiley:

Yeah, I added that due to the slower encode & compress stages…

2 Likes

It’s been pushed already? I’ve not seen this update come through on Steam

Your ‘local files’ tab in the HWRM Toolkit should say build # 1186731

See it?

It just came through for me now! :smiley:

For the “broken hods”, we just have some new findings:

When export a hod from Maya3, there’s an option to choose “Triangle Strip” or “Triangle List”. And if you use Triangle Strip, then RODOH won’t convert it properly, while if you use Triangle List, everything will be fine.

image

2 Likes

Wow - that’s weird. There are tons of old HOD files with strips (MANY MANY strips, ugh) - and it was loading and tri-listing those just fine… Care to send a broken one with that specific issue my way?

Here it is:
https://1drv.ms/u/s!Auz_2rWdhuE02HnBaKTGYliGPmA2

I am trying to convert some asteroids, but get an “ALERT: Unable to find map for shader [resourceNM]” message. The result is that none of the textures or materials get exported.

I tried adding “resource” and “resourceNM” to SHADER.MAP, but I keep getting the message anyway. I also tried copying “resource.st” and “resourcenm.st” from HW2C and putting them in the “data/shaders” folder, but it did not help. What should I be doing instead? Thanks.

[ed]

Here is my RODOH script:

= -$SHIP_NAME=asteroid_1_hw2c_test
= -$PATH_NAME=asteroid_1_hw2c_test
= -log
= -echo=-- Scan Path: $[SHIP_NAME]$[CR]
= -$CONVERT_IN=C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\DataMikaliMaps\resource\asteroid\$[PATH_NAME]\$[SHIP_NAME].hod
= -$CONVERT_OUT=C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\DataMikaliMaps\resource\asteroid\$[PATH_NAME]\$[SHIP_NAME].dae
= -do=convert
= -action=null
= -wait

Here is my MAP script:

+resource,resourceNM
	$diffuse[DXT1] = 1 1 1 1		# diffuse param
		DIFF = R G B 1
	$glow[DXT1]= 0 0 0 1
		GLOW = G G G G
		SPEC = B B B B
		REFL = R R R R
	$team[DXT1] = 1 1 0 1
		TEAM = 1 1 1 r	#invert into a...
		STRP = 1 1 1 g
		PAIN = 1 1 1 b
	$normal[DXT1]= 5 5 1 1
		NORM[B] = R G B 1

[ed]

It may be possible that there are no textures in the game for “resource” and “resourceNM”. Rather, they represent colors that are applied to the DIFF textures to make them appear full or depleted. I.e. a gray asteroid in HW2C becomes yellow after applying the yellow “resource” and “resourceNM” colors versus additional textures. Not sure though.