Rumble in the Jungle: Trial of Wisdom

in the quest rumble in the jungle, I’m stuck at Prove Yourself, Complete Trial of Wisdom, I’ve tried jumping down the platform into the magma, but every time the game tells me I died, but according to videos online, I should get teleported.

Please help me to either fix it, or maybe the mods can donate me some cash to revive, since I lost it all to this stupid glitch.

i feel like this is a funny statement, given how its…you know impossible

also, you should report this to bug report

You DO NOT have to jump in, if you back away and wait a bit, it will complete (and you save yourself the rez cash and a trip back through the jabber village to talk to the chief).


Bro it’s not a bug. Just wait for a few seconds. It’ll say you passed. It’s a joke

1 Like

I’ve tried everything and I can’t get this mission to progress. I’ve been standing on the ledge and backing up for minutes and nothing happens. It won’t check the box in the mission progress that says “go to the platform of wisdom” even though I’m standing on it right now. Gotta be a glitch.

This bug is happening for me now. Like the last poster, nothing I try works. I’ve jumped in the magma, it won’t complete, I’ve tried standing on the platform and backing up, and still won’t complete.

My first playthrough, I was able to complete this quest, so I don’t know what the problem is here.

I have one guess though, there’s an enemy jabber stuck behind one of the walls, nothing I do will cause it any damage, I wonder if that jabber being stuck there is what’s causing the issue. I could try restarting the game to see if it makes any difference.

I restarted the map and was able to get past this part of the quest.

A jabber spawned in the same spot stuck behind the wall, so I guess that had nothing to do with it after all.

The point where it seemed to stick before was at acknowledging that I had gone to the platform. So that’s the point at which the quest glitches out.