Screen flicker issue

This is a copy from my post on the Steam Community forum.

Hi all, so to start, I have tried disabling all the on-screen displayed on my system, that didn’t fix the issue, from there I messed with the different texture setting on shadows, and detail. Tried the different sync options, which adaptive helped an OK amount. Ultimately I tried lowering the texture size limit from the max of 8192 to 4096, that so far has fixed the issue, I even tried turning on the OSD’s again, and still no issue so far. My question is, is there any fix that would allow me to turn up the Size Limit back to 8192 without the flicker. I ask because the lower setting has now got my frame rate at sub 15 fps even with sync off.

I know there are patches in the works for this game, and they are going to take time due to the games unique engine set-up. Has anyone found a fix to this?

For a heads up my system is an Asus G551JW with an i7 4720HQ 8 GB of DDR3 and a GTX 960M with 2 GB Vram. So I should have no issues at the settings I am using which are near max.

Thanks all.

Update: Ok so after letting the game rest for a bit and relaunching it. Got it to play at a smooth frame rate, but flicker started again. So tried turning all the settings down to see which one is to blame by turning them up one at a time, well that was pointless, for it flickers even with everything turned down as low as it can go.

From what I can tell the flicker is related to my frame rate. which does not make sense. Anyone can help please, it would be greatly appreciated.

Update 2: I think I found the source of the issue, it has to do with the brightness and lighting of objects and backgrounds. In short. if am in a brightly colored map with lots of lighting, I will flicker badly, if I am in a dark map, as long as I avoid the light source, I don’t flicker. In short the lighting and shadow rendering in this game has a major set of bugs that cause the engine to freak.

Update 3: Its the HDR options that are causing the glitches.

Update 4: After serious testing, HDR options are not the issue, they exposed the real issue though. The game seems to not like any 16:9 resolution over 1600 x 900. Once I set it to 900p, the issues were gone. It seems a render issue with resolutions is the culprit.

Update 5: The resolution adjustment was not a true fix, after a restart of the game, the flicker returned worse than ever.

So any help with fixing this odd issue?

I have never heard of the issue you’re having… not once - and I wrote the graphics engine for HW:RM.

A 960 is a solid card - 2GB will be fine outside of 4-race MP maps, where it may struggle. But generally, it’ll be fine.

To me, it feels like some sort of overlay/screen-intercept software.

Again, having never seen this issue before, it is very, very hard to guess.

On my old computer which was using a Core2Duo and a GTS 9800M I didn’t have this issue, even with the Steam OSD. On both machines I am running Windows 10. So I am confused by this very much.

Found the issue, burried in Windows 10 is a Xbox PVR function that even in the Xbox app if you turn it off, sometimes it stays on in a kind of passive mode, intercepting screen data. I had to do a registry edit to force it off. After that the flicker stopped, I hope. On my older computer it was off because of my turning off functions during the install, my Asus though came pre-loaded with it on. I may be a unique case of this, but just in case I’m posting here so that if anyone else has the issue, maybe it can be solved easier for them.

1 Like

Sadly this didn’t fix the flicker. Once I went to the next mission it started again. With Frame sync off the combat view stops flickering, but it starts again once I go to battlefield map view, though in that view if I turn frame sync on the flicker stops. I am utterly confused. Its like there is to rime or reason to this issue. Not even after a re-install clean fixes it.

did you check the percentage of use of your cpu/gpu/ram when it happens ? Perhaps another program is monopolizing it in background ?

As far as I could find. Nothing is doing so now, yet the tearing style flicker persists. This is very perplexing.

Just an idea like this, even if I doubt that it could be this.
It’s a laptop from what I understood : could you verify in your nvidia settings that optimus is disabled or at least always force the use of the discrete card (the 960M) when HWrm is running ?
I don’t see how it would switch between the 960M and the integrated graphic during game (would be crazy oO), but we never know !

I have manually set it to force the rendering to the GTX 960M, so unless Nvidia drivers are pulling something I can’t see, it should be rendering on the dedicated card. When I tested it on the iGPU on the i7, it would not even launch. So something is going on, either with my laptop or with the game, the question is what.

Hi, just joined the forums because I have this exact same problem.

Recently purchased an Acer Predator 17 G9-971 with a Q6600, 16Gb RAM, and a GTX 980M 4Gb. Installed Homeworld and soon after launching I noticed a flicker when I run over the menu buttons quickly. Loaded into the game and the flickering just started happening. Mainly happens when zoomed in and panning the camera around to certain angles.

Originally I thought it was an issue with my power adapter because I had noticed that while gaming my laptop runs down the battery, however I contacted Acer support and they tell me that this is a design feature until the battery gets to 30% where it then throttles to use the adapter only (what a stupid design!). This was further supported because whenever I disconnect the power adapter all graphical flickering stops, have you tried that?

I’m stil waiting to hear back from Acer as to why, if its a design feature to drain the battery on power, I get flickering when on power but not off it.

Just a quick update, I found that by changing Frame Sync to V-Sync or Adaptive, that really reduces the flickering to nearly nil. What is also highlights is a diagonal screen tear when panning around quickly. A quick search online led me to the Nvidia forums at this link:
https://forums.geforce.com/default/topic/903422/geforce-mobile-gpus/diagonal-screen-tearing-issues-on-gtx-860m-870m-960m-965m-970m-980m-/1/

As you seem to have an Nvidia card as well I thought I might point you here to see if you’re having any other similar issues.

This is what is happening, but turning on sync doesn’t fix it. When I am at ship view with sync off, no diagonal tearing flicker, but when I go into map view, flicker, if I turn sync on, map view flicker stops, but when I go back to ship view flicker is back till I turn sync of. It gets unplayable in the later more bright maps. On my old laptop I was using a 9800M GTS, and with adaptive v-sync on in the drivers, and had no issue, but with my Asus, since it uses Optimus, I don’t have that option in the drivers. I’m very much at a loss.

Just tested, I set the game to render on the Intel iGPU. The tearing and flickering stopped. So its something with the GTX 960M. Finally headway on figuring this out.

I have a GeForce 840M. I just updated my drivers last night for the first time in a while, to fix an issue with DoK, and suddenly had the issue described above with HWR. Turning on vsync(via the nvidia control panel rather than ingame because even the menus were flickering and it was giving me a headache) resolved it.

Edit: On further review… not actually fixed. Improved, it seems, but not fully fixed.

Sadly I tried this, and it just made it worse.

I hope someone gets on this and figures out a fix, because this is a major bug, and it could be a sign I worse issues to come.

Yeah, from your past posts it didn’t seem like advice that would help you, but providing @bitvenom with more data might help in the long run. It sounds like you play in full screen mode, is that accurate? I’m playing in a window myself.

I also tried switching the nvidia control panel options back to application settings and using either of the vsync options ingame, with the same result with both. Menu flickering apparently entirely fixed and ingame flickering greatly improved but not gone.

I use my iGPU on the processor, the Intel video drivers don’t cause the flicker. I have tried both Window and Fullscreen. no difference, I have tried everything I could in drivers short of uninstalling all the Nvidia Drivers, and installing older drivers.

Nvidia released a new driver, do a clean install of it, it should fix the flicker issue. It did for me.

Thanks for the heads up, the latest driver fixed it for me too. Quite a relief.