Separate characters on PC and Linux?


(Michael Brown) #1

I loaded up B:TPS on Linux yesterday to play (I LOVE THAT I CAN!) and noticed my characters didn’t load.

Now that I see separate trading categories for PC and Linux - does this mean that PC and Linux are intended as separate character universes? Can I not play characters created in Windows in Linux and vice versa?


(Heyoo!) #2

My best estimate would be that if you’re dual booting installing tps on the Linux partition creates an entirely separate directory. Linux doesn’t play very well with windows so tps might not even be able to get to the windows partition and access your save data there.

I don’t know where character data is stored maybe you could transfer your stuff from the windows environment to Linux with relatively little problems


(Michael Brown) #3

Linux plays great with Windows! Full read-write support on NTFS has been here for a few years :smile:

Other way around, not as much.

I shouldn’t need to copy the save files manually if they are portable between environments - Steam should take care of the synchronization.

I strongly suspect they are different universes but am just looking from a “yeah that’s intentional” or “uhoh no that’s a problem” from Gearbox.


(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #4

you have to move your saves over by hand. i’ve never played TPS on windows, but i moved my BL2 over when i DL’ed it to linux.


(Nope ) #5

That’s weird. I played BL2 on Windows for a long time and a few months back I swapped to Linux, installed it in the latter’s partition and Steam Cloud took care of bringing my saves over. I really didn’t have to do anything. However, I haven’t even touched TPS on Windows, so I can’t provide more intel.

As you said yourself, Steam should take care of the sync. If you do not have Steam Cloud Sync turned off, I suggest you go look into it not on these forums, but by sending a ticket to Valve.


(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #6

Your windows saves are Save001.sav, which doesn’t work with Linux because Capitals. So they have to be renamed to save001.sav.