Serious mouse and vsync issues

edited: original post edited to better reflect results of testing.


vsync off: graphical tearing, but best performance.

vsync on: timed stutter every 4.5 seconds (or slightly less than 5 second intervals). sometimes 1+ seconds? inconsistent.

adaptive vsync: still exhibits tearing, although to a lesser extent than vsync off. also causes graphical tearing/artifacts related to UI and HDR bloom. lower performance. sometimes panning seems laggy.


top/left mouse input: moving the mouse slowly towards the upper/left direction fails to produce camera movement (at 4000 dpi, problem is worst, even at 200 dpi there is a noticeable 30% difference in lack of top/left input). other directions unaffected. (while rotating the camera)

logitech g400s, sapphire radeon hd 7850 ghz ed, catalyst 14.12

further comments might add some description to the problem, as it’s been revised.

Please visit our Gearbox Support page - file a ticket. Generally though, this is due to certain mouse drivers (often high-dpi)… I think you should be able to configure them to not do this.

just wondering, did you actually have someone test this or not?

certain mouse drivers

you mean ‘most’ mouse drivers. i haven’t seen a sub 1200 dpi set in about 10 years.

furthermore, i just tested with lowest setting: 200 dpi. it’s less noticeable but still there.

replicate: rotate the mouse in circles without lifting heel of palm from mat, and notice that view drifts towards the lower right direction because the top/left is not obtaining input as it should… it gets progressively worse with higher dpi settings (4000 dpi and there is almost complete lack of top/left input with slow mouse movements).

i rest my case, the issue lies with the game… fix now, thanks.

well, it seems the issues occur in both modes, regardless if vsync is enabled/disabled.

tested vsync on, issue still occurs, but the stuttering/jumping effect is masked by the fact that at 200dpi, the mouse stutters on its own, making large motions instead of smoother incremental pans.

also tested the top/left rotation issue with vsync on, also occurs… and tested the stuttering issue with vsync off. also occurs (but is masked by tearing)…

edit: the stuttering seems to occur at 4.5sec intervals with vsync on (but not adaptive)

as for the lack of top/left input on the mouse, that seriously needs a fix… it has nothing to do with obscure bounding box pixel problems… occurs in all modes (replicate: rotate mouse in spirals, it drifts to lower right of screen, should remain centered).

@xGeneStarwind- have you filed a support ticket yet? This will help us get some documentation of the issue in our system. Sorry for the issues here. I know how frustrating these sorts of things can be. If you can get that ticket filed, that will help our team get started looking into ASAP. Thanks for your patience!

yes, i just filed a support ticket (but that might take 2 weeks). surprised this isn’t a ‘known issue’, since it seems ubiquitous.

Great, having that ticket filed will help us get a resolution much faster.

Sorry GeneStarwind, I don’t mean to imply that DPI is the issue. It’s certain (very rare) mice with High DPI features resist being ‘re-centered’ and can jack the camera input loops up. If you attempt this with another mouse, does it persist? I heard of this only one other time during all dev - so I’d love to hear how alternate input devices affect your experience.

tested: mx518, logitech dual optical (old, old mouse, prob from 2003). same issue.

well, i tried all the dpi settings mentioned in the support docs previously, tried setting dpi to lowest and various levels, as well as polling rate, in the logitech mouse software. issue still persists.

however: i have 2x g400s, older mx518s/510s, i’ve never had an issue with these mice, ever. the g400s i’ve been running at 1600 to 4000 dpi at various times, no issues. (well, besides the fact that the 3 extra top buttons dont always work unless firmly depressed, but that’s a hardware issue, poor craftsmanship, all units i’ve received)…

edit: disabled logitech software, issue persists.


more testing: (problem is a bit different).

the vsync stutter seems to be happening on a timer (not bounding box related, as previously described). every 4.5 seconds roughly, but it’s exact, slightly less than 5 seconds between each tick/stutter.

it does not occur with the adaptive setting enabled, presumably some software method for approximating refresh? 30/60 fps step? not sure…

the issue with top/left mouse input remains (it can be reduced but not eliminated, still noticeable difference at lowest dpi). although, something fishy with the 4.5sec timed stutter on vsync as well.

Would you mind PMing me - If you wouldn’t mind I’d like to Skype with you - and attempt to determine how your setup (which you have certainly tested to various extremes) varies from others. Something is happening here. I would very much like to understand what so that we can either bring this to some sort of resolution, or I can research with more information in my pocket…

2 Likes

the vsync stutter goes away and disappears after a few seconds when you first enter game.

however, i’d like an fps cap at intervals 60, 90, 120. this way, it doesn’t experience star craft 2 esque burn outs and energy spikes/waste, and the slight lag that comes with vsync isn’t endured

If it’s like the original HW2 engine stutters can be fixed by disabling vsync and capping the fps to about 200.

I am having same probolem. Does not matter if I have vsycn on or off (I have 144hz monitor). As long as FPS goes above 60. This problem appear. Any slow movement of camera to the left or up is not being registered and it makes precise controling camera, and unit Z axis very difficult. This does not seem as mouse driver related, it looks like engine related. If I limit my FPS to 60, it is fine, but game does not look smooth to me and I do not want to play it this way.

Playing smooth here and no mouse lag using an Asus Rog Swift 144hz Gsync 2560x1440 display, using gsync mode @ 120hz with sli disabled, gsync does not work with sli enabled but works fine with 1x gtx 780

After turning Vsync off on my machine, there is zero mouse lag and frame-rate lag.

Guys, this is not about delay or lag. Read main post. There is problem for some, where camera movement is not being registered, when you move it to the left or up and very very slow. This happens only if you actualy rotating camera itself, that means holding down mouse button. And it is same for changing Z axis for units. for me this appear when my fps are above 60, no matter if I have vsync on or off. Can you try it?

re (vsync) —

i haven’t noticed the vsync stutter to go away, at least not during 10+ minutes of testing, it’s timed at 4.5+ seconds exactly.

also, inb4, the ‘adaptive’ vsync option works in hw1, but in hw2 it causes plenty of bugs. vsync off causes massive tearing.

and i was under the impression that the adaptive option does just that. either caps the fps to the screen refresh rate or something similar. although i have no technical details, and have not bothered to monitor with a dx recording app.

re (mouse input) —

not much else to be said. problem exists, for some, maybe not others. depending on dpi in software can be reduced but not eliminated. no other options make a difference, including uninstalling software/drivers, or a different mouse. on a clean machine… win7 x64 pro.

anyways, list of 50-100 bugs incoming. hw2 display/ui is broken, causes screen artifacts/glitches. yawn…

Just tried the new patch and the mouse issue still persist. Very annoying.

What’s your desktop display refresh?

My monitor does just 60Hz, I saw someone mention that if the frame rate was below that it would eliminate the issue but after playing around with vsync and adaptive, and had the game running below 60fps, there was no effect, and mouse still was unresponsive moving up and left slowly.