Settings Will Not Save. Help Please!


(Brad) #1

I just got Borderlands 2 and the Pre-Sequel on PC. I bought it on steam during the winter sale. When I launched the game from steam it opened up the Borderlands launcher and I’d figure I’d change the graphic settings before I start. So I changed the settings to my liking then hit “Apply”. I then got a message saying: Failed to save your settings. Could not find ‘C:/Users/brad1/OneDrive/Documents/MyGames/Borderlands2/WillowGame/Config’. I don’t know why it’s looking in there. I’ve saved everything into my D drive I believe and that’s where steam and my games are saved. I don’t even have OneDrive installed currently. I tried going in game and changing the settings and that also did not work. I’ve been trying to find a solution for a while, but I’ve had no luck. Any help would be amazing thanks!


Game "NEVER" saving
(Isthiswill) #2

In steam go to settings under the leftmost menu. Select downloads on the left and verify that the game library on the right where your games are installed where you think they are. It will loist5 the full path of any save locations on connected drives and allow to add one if it is missing.


(Going Down The Road Feeling Bad) #3

The launcher settings will be saved under your user’s Documents folder. Is your Documents folder under C:\Users\brad1? Check if there is a C:\Users\brad1\Documents\My Games\borderlands2\willowgame\Config folder. That is where they are normally saved.

Also, right click on Borderlands 2 (on the left panel) and select Properties, under the LOCAL FILES tab, try Verify Integrity of the Game Files…

There will probably be one file that gets re-downloaded, but that shouldn’t affect the config or saved games, but it wouldn’t hurt to check.


(Brad) #4

Thank you for the response! I went to my C:\Users\brad1\documents and the folder was empty. However when I go to the document tab that’s on my quick access list it shows a folder for Overwatch and League of Legends. I also tried validating the files in steam by right clicking and doing all of them. When it’s finished it says: 1 file failed to validate and will be reacquired. AFter it does it’s thing nothing changes. I’m still not able to save any of my settings and they keep saying Could not find ‘C:/Users/brad1/OneDrive/Documents/MyGames/Borderlands2/WillowGame/Config’.


(Is this thing on?) #5

It sounds like your user account on your computer has been set up to save all documents to OneDrive by default. This link may help:

The one file that you saw mentioned on verify files is something to do with the Steam/game DRM check, and you can completely ignore it.


(Idiosyncratic Wannabe.) #6

Also double check that the my documents isn’t being protected by your anti virus. I know for instance that with every new game I have to manually tell Bitdefender to let the game edit my documents.


(Going Down The Road Feeling Bad) #7

This link discusses a problem with Win10 upgrade to 1809 where Known Folder Redirection may have caused the Documents folder to be moved to OneDrive:

Maybe you installed Borderlands 2 after a Win 10 upgrade?

Check your Documents folder Properties using the link that VaultHunter101 gave and make sure that the save location doesn’t include OneDrive.

If you find that the save location is not set correctly and fix it, Borderlands 2 MAY be able to locate the correct Documents folder. If Borderlands 2 still tries to save to OneDrive, the you will probably have to uninstall and reinstall after making sure the Properties for the Documents folder save location is the way you want it.


(Brad) #8

Okay so I went to documents and saw that there was OneDrive there. I followed instructions and moved everything to the right one. I then completely deleted OneDrive off my PC. I then deleted Borderlands 2 and reinstalled it. Then verified the files just in case and launched. I then tried to save settings again and it said the same thing as before. There is one thing that I checked. All the files in my D drive are set to read only. I manually went to properties and changed them to no be read only, however it seems like they didn’t save cuz I went back and it said read only again. I don’t know if this has anything to do with Borderlands messing up.Again I appreciate your time :slight_smile:


(Is this thing on?) #9

Sounds like AV software is locking the folder hierarchy. You’ll need to create an exemption in whatever you are using (Windows Defender, Bitdefender, etc.) to prevent this.


(Going Down The Road Feeling Bad) #10

You moved the files, but did you verify that the Documents Properties save location was set correctly? Maybe you need to re-boot after changing the save location for the Documents folder.

If it is set correctly, then maybe uninstalling Borderlands 2 leaves some files around with your local settings.

Check where Borderlands 2 is installed. For me, it is in “C:\Program Files (x86)\Steam\steamapps\common\Borderlands 2”, but it would depend on where you installed your Steam games. The same “LOCAL FILES” tab where you verified the files has a button for “BROWSE LOCAL FILES…”. That will show you where it is installed.

After uninstalling, check if anything is still in the “Borderlands 2” folder under “common”. If there is, then delete the “Borderlands 2” folder and empty the trash (rebooting the PC wouldn’t hurt). Then re-install Borderlands 2 and try to apply your settings.


(Brad) #11

Everyone I fixed it! Thank you all so much for the time and effort you put into helping me. I truly do appreciate it. I was looking into similar situations and somehow stumbled onto a steam post. Someone was having a similar problem and said something about Ransom Protection. I guess there was a setting that was set by windows that was interfering with my folders somehow. I don’t really know what it did, but I turned it off and tried Borderlands again. As soon as I hit apply it actually worked! I’m so happy now. It’s been so frustrating trying to fix it especially when I have no idea what to do lol. Again thank you everyone for the help!