[Severe HWR bug] Multiplayer Load crash for some players when AI is Kushan

Just like ti says… I didn’t experience it myself (while playing alone/pubs) but my best friend whom i play with, always, ALWAYS, CTDs to desktop either upon the loading bar reaching “Universe” or once the map loads completely, IF one of the CPU AIs is set to play as Kushan. All other races work fine for the CPUs but the moment either he or i host a game (password protected) and one of the CPUs is set to Kushan, he always crashes. I load just fine. Anyone can give any feedback on this? It’s really frustrating. And this happened since pre-patch.

Edit: We have tried this on both Steam multiplayer and LAN MP using tunngle.

Does he have a graphics card with 1 gig of memory? If so, try dropping the max texture size down to ‘2048’ (on his system) and see if it still crashes.

1 Like

Will do and i’ll post about it as soon as we’ve tested! Damn i never imagined Kushan could be possible memory hogs.

It’s a guess. The HW2 races are easier on memory than the HW1 ships. If your best friend has a video card without a lot of RAM, playing against 4 different races is going to be demanding. If it works that is what is going on.

1 Like

By Joe that was it! It fixed it! Thanks for the info!

Excellent, glad it worked.

One more thing though. Last night i got a crash… like 1hr 10 minutes in a game. It was a Not Responding hang crash. Could it have been that i was running on 4096 limit? My settings default set 8k to green yet i didn’t want to push it too hard since i was also streaming with OBS. I didn’t find any crash log… maybe i didn’t look where i needed. All went fine untill i activated the sensors screen (space) and then it zoomed to half the sensor screen zoom and hanged. Any ideeas?

It’s probably not the same thing as the game loads all the ships referenced at the start of the game (hence your best friend’s crash). Probably something else :frowning:

Putting this here to potentially help other users that experience the same thing, if you crash around “Universe”/right at the end of loading into a level and your HwRM.log file has a series of:

EngineTrailStatic::getTweaks requesing index(0) that doesn’t exist

then your video card has run out of memory.

  1. if playing Player VS CPU reduce the number of unique races

or

  1. Lower your texture quality size limit to below 4096