[Solved] Black screen with sound/music at launch

Hello,

Homeworld RM is launching with a black screen since I changed my gpu. It doesn’t crash, the intro movie, music/sound are playing but nothing on screen. It happens with both classic & RM versions.

I went from an AMD to a Nvidia GPU. I reinstalled Windows (10 x64) for the occasion & did the same for Homeworld RM. I have the latest drivers (368.69).

Specs :
I5 4690K @4.2Ghz
16Go RAM
MSI 1070 @stock

What I did before posting :

  • Checked .NET & C++ runtimes
  • Changed Nvidia settings to performance mode & “let the application decide” mode
  • Launched the game in windowed mode
  • Deleted the profile folder
  • Verified the files with Steam
  • Tried launching in different compatibility modes (W7, W XP)
  • Don’t have any OC or overlay software
  • Made the necessary exception for both the launcher & RM exe on my AV software

I’m really at a loss now. I don’t see what more I could do. It reminds me of the issue with Nvidia & IGPU on laptops ~ But it’s a desktop & my IGPU is definitely disabled in BIOS. Also tried to change some Nvidia settings that could be related but without success.

If anyone can help, that would be great.

Linking my log file in a 2nd post.

Thu Jul 14 07:10:49 2016 Version 2.1, Build Number 31, Changelist Number 1237961 Loaded Archive: 'Homeworld2.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateHomeworld2.big' Loaded Archive: 'HW1Ships.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateHW1Ships.big' Loaded Archive: 'HW2Ships.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateHW2Ships.big' Loaded Archive: 'HWBackgrounds.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateHWBackgrounds.big' UTIL -- filepath failure, path doesn't exists 'D:\Jeux\steamapps\common\Homeworld\HomeworldRM\data\locale\English' Loaded Archive: 'English.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglish.big' Failed to Load Archive '..\..\DATAUPDATES\Compatibility.big' Loaded Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\HW1Campaign.big' Loaded DLC Campaign Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\HW1Campaign.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateHW1Campaign.big' Loaded Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\EnglishHW1Campaign.big' Loaded DLC Campaign Localized Data Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\EnglishHW1Campaign.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglishHW1Campaign.big' Loaded Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\EnglishSpeechHW1Campaign.big' Loaded DLC Campaign Speech Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\EnglishSpeechHW1Campaign.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglishSpeechHW1Campaign.big' Loaded Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\MusicHW1Campaign.big' Loaded DLC Campaign Music Archive: 'D:\JEUX\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\MusicHW1Campaign.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateMusicHW1Campaign.big' Uing ..profiles\ for profiles folder GAME -- Using player profile Eozen Changing from a 32 bit colour depth in winNT (6.2 build 9200), Display: (0, 0, 1920, 1080) - (8, 31) GL Info: 4.5 - 4.5.0 NVIDIA 368.69 GL Vendor: NVIDIA Corporation GL Renderer: GeForce GTX 1070/PCIe/SSE2 GL Part ID: 1070 GL Part EX: /PCIe/SSE2 Loaded Archive: 'EnglishSpeech.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglishSpeech.big' Loaded Archive: 'Music.big' Failed to Load Archive '..\..\DATAUPDATES\UpdateMusic.big' SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created SOUND -- created destination [ dxa streamer ], handle [ 0 ] with [ 8 ] channels created SOUND -- created destination [ dxaudio ], handle [ 1 ] with [ 48 ] channels created Build name: Data path : D:\Jeux\steamapps\common\Homeworld\HomeworldRM\data Font Load: data:UI\Font\Blender.rcf, 1920,1080 Font Attr: 14, Biu No mapping for font 'Blender' - using 'default' Resetting fp PC control word. CmdLine: -dlccampaign HW1Campaign.big -campaign HomeworldClassic -moviepath DataHW1Campaign

I’ve had this problem happen sometimes, and the solution is just to hit escape to skip the cut-scene after it ends.

Thanks for the answer.

I already did but the black screen persist on the menu. I can hear the cursor hovering sound on menu boxes.

In H2 classic I even have a UI box appearing but corrupted. I’m used to troubleshoot things like that but this time, I’m completely at a loss.

Something is likely wrong with your graphics driver if all 3 games are black screens.

Completely uninstall the video driver and maybe try an older video card driver.

1 Like

Thanks Cloaked. The 368.69 driver version is the culprit.

Updated to the 368.81 version which got out today and it’s working!

Well, let’s finally try to finish the H1RM campaign :slight_smile:

1 Like