[SOLVED] HODOR animation channels error

I am setting up an animation, but HODOR is throwing a strange error:

image

I’m not really sure what animation channels are… “Trp_Ecm_LHS_Wing” has postion, rotation and scale keys, and gets the error 3 times. I tried removing any position/scale keys left on “Trp_Ecm_RHS_Wing” (I am only using rotation), and got the error once, as above…

Any thoughts?

In your menu right there it shows duplicate rotation key frames. How max does that, I don’t know, but that has to be the issue.

That, or you have another item of the same name that isn’t obvious… It happens sometimes. Send me your DAE?

1 Like

Ok, so it turns out that “dupe” means “duplicate”, for people who are too lazy to type “licat”…

Anyway, I was trying to animate the collision mesh as well and had some joints with the same name in the square brackets, so that was the cause. However, things are still not going well in that HODOR now generates the MAD and HOD files without any animation errors, but refuses to play the animation in game… Fairly sure its not a scripting error as I tried using the HOD with the hgn_ecmprobe (which has the same animation name “Open”) but it still didn’t work.

I would be very grateful if someone could have a look, I have no ideas left on what could be wrong. My collision mesh has an “Unable to locate Geo instance under Root” error even though I have reset the Xform a million times - not sure if that is affecting the animation?

DAE file:

Argh, I thought I had animation nailed!

All these -pivot objects might be doing something funky - @bitvenom would have to confirm if that’s the case.

As for the geo/root error, under ROOT_LOD[0], create a JNT[Probe] and place the MULT[Trp_ECM]_LOD[0] object under that. Should get rid of the error, I think.

Finally, don’t forget that the animation playing in-game depends on the .madstate file working correctly.

I got it working! Turns out I had the end time wrong - it needs to correspond EXACTLY to a multiple of 30 when working with seconds, in a 30fps world.

3 Likes

Awesome ! I already thought I messed up the animation somehow in the end :sweat_smile: