[Solved][HWR Modding Help] Can't get a small mod to load

Greets.

I’ve taken my first crack at modding (read: just changing some numbers) for HWR. I settled on something silly and simple: Make the Kushan ion frigate OP by making it cheaper, tougher, and giving the ion beam a substantial firing arc.

The problem is that I cannot get the mod to load using any method I’ve come across for modding HWR. I unencrypted and extracted the shp and weap files, edited them, repacked them into a mod .big (using old HW2 tools) named Superion.big, and…

  • Dropped that .big into HomeworldRemastered/Data, then launched with a shortcut using -mod and -overridebigfiles.
  • Dropped the .big and a keeper.txt into HomeworldRemastered/DataSuperion, then launched with -moddaatapath.
  • Attempted to launch with loose files in HomeworldRemastered folder.
  • Created a “dummy” Workshop mod with a string of numbers in the folder name and the text file therein to get the mod to show up in the HWR launcher’s mods screen (it didn’t).
  • Replaced the .big of a working mod with my .big, renaming it to that mod for the purposes of testing - launched with that .big and the changes did not stick (e.g.: the cost of the frigate was unchanged)

And now I’m at a loss. Do I absolutely need to upload to Workshop and go from there?

Thanks

You shouldn’t need to make a .big to load a WIP mod, even less go through the workshop.

Dropping the files in …\Steam\steamapps\common\Homeworld\HomeworldRM\Data\ always worked for me. You can create a shortcut manually to Homeworld\HomeworldRM\Bin\Release\HomeworldRM.exe with the -overridebigfile command line (check the spelling, no s at the end), or just add -overridebigfile to your launch options in Steam (the HWR launcher will pass them along to the game exe).

If this still doesn’t work, making sure the folders and files are spelled correctly would be the first step. Also see if everything loads properly in your HWRM.log

AHA. I think my fatal mistake was putting that “S” on the end of the override command. With -overridebigfile and loose files it’s loading fine now. Thanks a bunch.

A second question: If i wanted to make an ion cannon have a 90 degree firing arc from the emitter on the front of the ship, would I change the appropriate .weap line to:

setAngles(NewWeaponType,90,0,0,0,0);

…if that first number indicates the angles at which the cannon operates? I’m essentially trying to get this beam to act like the Cataclysm style multi-beam frigate ions.

I believe so. The four other zeroes in that function correspond to the angles for AnimatedTurret-type weapons, but Gimble-type weapon (which kus_ioncannon is) only use the first.

An example of wide-angle gimble-type gun for reference would be hgn_mshulldefensegun

For giggles, I threw the new 90 degree ion beam onto the Interceptor. In that case, the weapon doesn’t fire in an arc but only directly forward. Is there something in the Interceptor ship file that’s preventing it from firing in an arc? I did something similar in Cata when I threw the MBF beams onto Acolytes and it worked perfectly.

I’ve got a related question to this issue and I feel silly for not getting it as this used to be 101 back then.

I’ve got a custom folder with my loose files in it. Placed my mod folder or rather yellow13 his mod folder (Somtaaw) here:

D:\Steam\SteamApps\common\Homeworld\HomeworldRM\Data\somtaaw

So it’s in the Data folder.

I’ve created a shortcut and added the following lines at the end of the targetline:

-moddatapath Somtaaw -overridebigfile

I’ve also tried this as pointed out in Botman’s guide:

-datapath Somtaaw -overridebigfile (Somtaaw is the modfolder name)

What am I doing wrong?

Edit: Ah nevermind I’m probably just tired of course I need to isolate the sub folders of the mod folder… ^^

Also, make sure you have a ‘keeper.txt’ file in your mod folder (since that’s what the engine looks for when loading a mod as loose files).

1 Like