[SOLVED] Model Scaling Issue

Hello, I am having an issue with a model of mine.

The problem is that my ship model is scaled to the proper size it should be., however all the turrets on the ship are much smaller than they should be… You can see how tiny they are in the pics below, and kind of get an idea of how big they should be based on their “bases”.

I model my models in Maya, then import them into 3ds Max to apply the dummies and assemble the hierarchy. I’ve found that scaling the models in Maya is the best way to go, and the model and its parts are the correct size all the way through the whole process until I test it out in-game…

I was previously having a problem where ALL the objects were the wrong scale, but now I’ve got the ship’s model correctly sized but the turrets are still having the scaling issue… Anyone have any ideas?



Reset Xform on everything before export?

1 Like

Yep, reset the XForm for all the objects of LOD0 and also reset the collision mesh.

EDIT: I don’t have to reset the dummies right? Haha

Actually you do. At least I remember that year ago when I started playing with HODOR, I had my BC three times as large, because my Root dummy didn’t have scale of exactly 100.
Take a look at scale values of your turret dommies.

Hehe, dommies

It’s your clones’s names.

And @Pouk has his Poukkies :joy:
― Sun Tzu, The Art of Modding

1 Like

Man I wish, but Poukkies are not yet existent. It all depends on whether Talros lends me his clone tanks. He’s German, so I could just take a four and a half hours train to him, if the tanks are too big to move.

I decided to put this model on the backburner for a little bit until I fix the scaling problem, so I started work on another ship, a corvette-class ship. I’ve got this ship fully rigged and everything, and I’m having the scaling issue again. I’ve gone through multiple versions and have reset all the scales of everything in my scene to an even 100 AND reset their XForms. STILL have a scaling problem, they are far too small (they should be about the same size as the Multi-gun corvette in the picture below).

I don’t really know what else to do… Any suggestions?

Units?

Didn’t even realize what units I was set to, I’m set to “Generic Units” (I think 1 unit= 1 inch). The units don’t matter for the scale though, right? As it is basically an arbitrary number, not measured the same as transform is.

Are you saying the whole corvette is scaled wrongly or just parts of it?

I use cm as units when importing / exporting the dae files.

Ah, when exporting I have it set to centimeters, like your guide suggests. Yeah, the entire thing is scaled wrong.

EDIT: I figure it is the Root dummy that is causing the problem, since everything is scaled down. The dummy must scale back down Everytime I reset it’s XForm. Is there a way to override that?

1 Like

Sorry for the double-post, but does anyone have any suggestions on how to fix this issue? It’s a big mountain in the way of my progress at the moment :confused:

I’ve tried resetting the XForm of the root dummy unlinked from everything else, so the meshes aren’t affected, and then re-linking everything back up with it. However That didn’t seem to work…

Upload your DAE.

Messaged you the file.

I thought that dummy scaling was ignored, only rotation and position were exported. I have all my dummies as 1x1x1 meter boxes

His Root dummy object has a scale of somewhere around 250. It does affect the final scale in game.

1 Like

SOLVED!

Alright everyone, the problem was that I created rigged my mesh in inches and I was exporting in centimeters. Since there is 2.54 centimeters in an inch, that is why my model was about 2.5 times smaller than it should have been! I ended up exporting my DAE in inches so that my ship does not scale in any way.

NOTE IF ANYONE RUNS INTO THIS PROBLEM: When you are exporting, look under advanced, uncheck “Automatic”. Look up to the top left a little bit and you should see something that says “Scale Factor :‘x’”. In a perfect world you will have your measurement set to “centimeters” and the Scale Factor will say “1.0”. But I advise that you select a measurement that will make your Scale Factor say “1.0”, in this case I had to set it to inches.

Here are some pics and glam shots of the ship :slight_smile: Once I fix the destroyer as well I’ll post a pic of that one too.

4 Likes