[SOLVED] Player initialization failed on PC - Steam version

Hello! First of all, congrats on the game release!

I’m still having the same problem I had on CTT and Beta, previously discused here: Player initialization failed on PC

image
English text: “Player initialization failed: Failed to complete the patching process. Please check your network connection and try again.”

Please can you help me? Thanks in advance!


UPDATE: As always, GBX was there to listen and the last game patch (23/5/2016) fixed this issue:

“Fixed a “Player Initialization Failed” error when users first attempt to sign in.”

Thanks a lot to all the Gearbox team. You guys rock and I’m so sure that the love and effort you put in Battleborn will pay out well at the end. :clap: :confetti_ball: :grinning:

1 Like

same here

I’m having the same problem. Telling me player initialization failed, battleborn inventory operation timeout.

Having the same issue

Wow, come home to play me some Battleborne and hit with this thing :frowning:

1 Like

This is occurring across all platforms. I guess they’re updating or tweaking something hard.

it just started happening 4 rs ago for me went home to play some BB. this is just extremely frustrating please fix this fast.

In my case this is not related to the server tweaking, I had this for a long time and coudn’t pass the error window from the screen capture above :sob:

Zendesk ticket: #105197

1 Like

+1 Same issue.

Haven’t been able to play for last 2 days.

im still unable to play due to this bug has anyone figured it out?

Nothing here. I still can’t play it either. Best advice that support gave me was to logout/login from Steam a few times before starting the game. Try it and tell me if it works for you…

I wonder if they will tag this as a game issue and try to fix it. Pre-ordered digital deluxe version is getting too much dust :frowning:

This is killing me it works on other ppls computers all my friends are playing i checked everything and there is no explanation why this is happening.

Same here… :cry: checked every log, configuration… everything looks fine. Old and new games play well with my current setup, but not this one.

Did you try re installing steam?

Yeah, even that… it was a pain to redownload all my collection again… You can also try a less aggressive method flushing Steam configuration with: steam://flushconfig

i did that to i have no idea it just so lame.

As always, GBX was there to listen and the last game patch (23/5/2016) fixed this issue:

“Fixed a “Player Initialization Failed” error when users first attempt to sign in.”

Thanks a lot to all the Gearbox team. You guys rock and I’m so sure that the love and effort you put in Battleborn will pay out well at the end. :clap: :confetti_ball: :grinning: