[SOLVED][UI] Key bindings since patch?

you talked about “a right-click context menu, which doesn’t even seem to be present anymore”, so I was confused and thought you were talking about the shift+right-click thing, as there never was a direct right-click menu in HW2 as far as I can remember (or am I wrong and my memory has a big hole in it ?)

I see that P and ; are good choices. Is everyone 100% sure they’re not bound to something else?

[edit]

Also, where do I do the actual binding? I see there is a “controlstab.lua” script, but I’m not sure that’s the correct file.

[edit]

Never mind. I found what I needed in “locale\scripts\keybindings.lua”.

[edit]

That is indeed the correct file. However, I can’t figure out how to type the semicolon and comma variables into the table. Is it COMMAKEY? Or just COMMA? I dunno.

I’m trying to add the P, comma and semicolon keys to the following file:

“locale\english\scripts\keybindings.lua”

The codes for the regular alphanumeric keys match the common ASCII codes. For instance:

PKEY = 80
ZKEY = 90
FOURKEY = 52

http://www.asciitable.com/

I was able to find the code for the P key easily. However, I searched every Lua file as well as the globals dumps, but couldn’t find the codes for the comma and semicolon keys. The numbers from the ASCII table didn’t match. I tried COMMAKEY and SEMICOLONKEY, but they didn’t work either.

Not sure where else to look. :frowning:

[edit]

Here’s the UI globals dump.

[edit]

I was able to determine the correct code by editing my profile’s control bindings, and then examining the output in my profile’s “PLAYERCFG.LUA”. The codes get saved there every time you change a binding.

FYI, the semicolon is #186, the comma is LESSTHAN.

You have a Qwertz keyboard, haven’t you ? ^^

Edit : Dwarfinator = derp over 9000

LESSTHAN is Shift+, …

No. I have a QWERTY keyboard.

What keyboard do you use? I may have to create different bindings for each locale… :frowning:

Yeah, I don’t know what I smoked when I said that, sorry :cry:

I don’t know enough about non-English keyboards/locales, so I will use the same bindings for all until someone complains.

QWERTY. “<” is obtained by holding SHIFT then pressing the COMMA key (or in this case, it became the LESSTHAN key).

Only the LESSTHAN variable works. I tried COMMA but it was a no-go.

    { 253, "UI_ToggleScreenGameRubrick( 'InGameMenu', 'ProgressScreen', 0, gr_all)",				INKE_KeyDown, 0, 	"Team Progress Meter", 		{ LESSTHAN } },	-- comma

I wonder if the same thing happens with the ‘.’ (period) and ‘>’ (shift+period) keys…

Yes it does.