[SOLVED] "Unknown Type" RODOH error

Hi all,

Been trying to find a way to fix old HODs en masse that give this result in (old) RODOH:

G:\Games\Homeworld 2\Modding Tools\HODOR>"D:\Game Files\Steam\steamapps\common\Homeworld\GBXTools\HODOR\RODOH.exe" -script="G:\Games\Homeworld 2\Modding Tools\HODOR\single_extract.hodor"
-- Scan Path: G:\Games\Homeworld 2\Modding Tools\HODOR\HOD
Converting G:\Games\Homeworld 2\Modding Tools\HODOR\HOD\fed_ENT_shuttlepod.hod
DAE not saved to G:\Games\Homeworld 2\Modding Tools\HODOR\DAE\fed_ENT_shuttlepod.DAE
 - Unknown type:
 - Unknown version: 00000000
Scan Complete!
Press any key to continue . . .

My bug hunting methodology so far has been to delete everything in the old HOD, item by item. I ended up with a completely empty HOD and it was still giving that same message. I then exported the OBJs, imported them into MAX, exported them and then replaced the meshes in the HOD. That also didn’t work.

I tried looking for a type or version number in the old HOD in Notepad ++, comparing it between ones which worked and ones which didn’t, but the guts of a HOD aren’t very human readable -_-

Has anyone gotten past this yet? We have 172 HOD files out of 346 which didn’t convert through and we are hoping to do a release sometime this year. If I can’t fix the old HODs to work with RODOH that’s not going to happen :frowning:

I get the feeling it’s CFHodEd that’s the issue, or rather, the latest version of it. I tested a few old models I made, and they didn’t work (got the Unknown version error). I happen to have an older version of CFHodEd (v 3.2.0, back when it was CFHodEdTangent), so I opened the HODs in that and just saved them, and as if by magic, the hods worked, and RODOH spat out 2 DAEs.

I noticed that one of the HODs you were having a problem with was the ENT shuttlepod, so I cheekily extracted it, resaved it in CFHodED 3.2.0, and, well…
image

So that leads me to believe that CFHodEd 4.0.2.4 doesn’t write certain chunks in the HOD correctly. Not sure what it does differently, but I know that version 3.2.0 saves versions that HODOR does like. Very strange.

1 Like

image

So… let me run the numbers… it would take 3 or 4 hours for me to manually recreate a HOD in MAX without a starting point, there are 172 HODs to do… that’s 680 to 700 hours? You have literally saved me 700 hours of work :astonished:

2 Likes

Hehe. Glad I could help. It does save a helluvalot of time, and it’ll be helpful for other devs too!

1 Like

That’s probably because you might want the 4.0.2.4 version, the most up-to-date pre-remastered CFHodEd.

Yeah for release in one week !

What ? Why no ? :stuck_out_tongue_winking_eye:

1 Like

As it turns out, I was wrong on the CFHodEd version number. I checked the version of it and it is 4.0.2.4, an easy enough mistake to make. But the core point still stands. :slight_smile:

I actually had 4.0.2.3, I’ve grabbed 4.0.2.4 now.

There are just 10 HODs left to convert at the moment, on a preliminary count. They had an overflow when saving in CFHodEd Tangent.

Still, it’s a fantastic achievement @CMDBob :wink:

//EDIT

Just to clarify, both version 4.0.2.3 and 4.0.2.4 have the same issue. I think the reason CFHodEd tangent won’t open those particular files is the mesh sizes. I’m thinking to auto-optimise the hell out of them, then bring the proper mesh into Max and then later swap out all the lattice work on them with matt_scissor flat panels :wink: