[Steam] Connection issues

Anyone else having these? For some reason Battleborn keeps saying my steam account disconnects but it doesn’t…so it boots me out of my current game. Has happened at least five times in the last match I played.

1 Like

I don’t know about Steam but yesterday I could play fine, now the game won’t let me sign in for no reason, it keeps signing in forever and then error message : player authentification failed or invalid service selected.

I managed to sign in once, all my stats showed at 0 and it took ages to load the Command menu. I tried selling some items and I had to wait 5mn per item in order to sell them lol.

Finally it booted me back to sign in with another error message and now I keep getting invalid service selected error straight up. G ■■■■■■■ G.

I had that happen once - yesterday, I think - but that’s the only occasion I can recall.

The unwelcome quirk I’ve been encountering lately isn’t steam-related and seems to be associated with character selection screens:

Over the last week, I’ve noticed a lengthy matchmaking and disconnects by other players- and in the last 48 hours or so, I’ve started to have Battleborn bug out on me regularly but I’m not sure if that’s just a coincidence with recent game updates and recent nvidia driver releases. I don’t know if other people are also experiencing technical issues - for some reason hanging going into or out of the character selection phase in multiplayer story mode seems to be an issue, or it least it seems to happen at those transitions - but when it occurs, I can generally restart battleborn and rejoin the game without difficulty. If many other people are experiencing this sort of thing, perhaps it’s at least contributing to the problem matchmaking issues.

It could just be me - but it’s a little strange that the game seems OK otherwise. I just had this happen while trying to start an advanced game of the heliophage, locked up on the way to character selection, connected just in time to see the last other player disconnect from the party character selection screen, and get dumped into the game as miko. At least it defaulted to my top gear loadout. While I didn’t successfully destroy the crystals in time, the game itself played fine even if miko obviously wasn’t ideal for soloing the heliophage.

I’m a bit puzzled - everything has been solid for me previous to the last few days. I’ve my running the current nvidia game ready driver under windows 10.

The error I get is:

t:\POPLAR-PCP\Development\Src\Render\RenderD3D11\d3d11Render.cpp(210): Assertion failed: RenderAssert:
Device->CreateRenderTargetView(Texture->Texture2D, &rtv, &Texture->RenderTargetView) - HRESULT 0x887A0005 - DXGI_ERROR_DEVICE_REMOVED - The GPU device instance has been suspended. Use GetDeviceRemovedReason to determine the appropriate action.

Fatal Exception: 0x0000dead, GetLastError: 0
Map: MenuMap_P, Changelist: 1221181
Address = 0x00000001FBEA1F28 [in C:\WINDOWS\system32\KERNELBASE.dll]
Address = 0x00000000000C58AF [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x00000000007402EF [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x0000000000DCA71A [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x0000000000DC9F2F [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x0000000000DC3304 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x000000000073D86E [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x00000000009BB134 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x00000000009DBBC2 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x00000000009BBE6C [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x0000000000540E35 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x0000000000541369 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x000000000010EF02 [in C:\Program Files (x86)\Steam\steamapps\common\Battleborn\Binaries\Win64\Battleborn.exe]
Address = 0x00000001DC633FEF [in C:\WINDOWS\SYSTEM32\MSVCR110.dll]
Address = 0x00000001DC634196 [in C:\WINDOWS\SYSTEM32\MSVCR110.dll]
Address = 0x00000001FC158102 [in C:\WINDOWS\system32\KERNEL32.DLL]
Address = 0x00000001FEC9C5B4 [in C:\WINDOWS\SYSTEM32\ntdll.dll]
Address = 0x00000001FEC9C5B4 [in C:\WINDOWS\SYSTEM32\ntdll.dll]

Just happened to me.
Was playing Story mode Advanced with one random player.
They got disconnected, came back and said "Sorry, got dropped"
About 2 minutes later I’m booted to the main screen with a message that the Steam was gone.
So first thing I do is check the Battleborn Steam forums, and they were working.
This obviously is more of a bug than a Steam problem since I was connected and had access to the forums.

I am having the same issues since an Hardware upgrade plus upgrade to Windows 10. Did you come up with an solution so far? I am talking about the dxgi_error_device_removed. I am open for any idea.

Yeah I get this on average once a day.
Anyone else have any more info on this?
The nature of the error means hardcore mode is a no go because I run the risk of a disconnect which counts as a death.