Steam Link issues

Hi,

I tried to play with the Steam Link but I have the issues mentionned here:

In short there is two issues when starting Borderlands3.exe with Steam Link:

  • Steam “lose” contact with the application (game not showing as “Playing”), so after invoking the Steam overlay it’s not possible to get back to the game
  • The xbox controller is not recognized and work as a keyboard/mouse emulator (possibly because of the first issue).

Could you take a look at this?
Thanks in advance.

1 Like

It hasn’t been working for me either and this is the first game I’ve ever had problems with, Epic or otherwise, with Steam Link. I’m using an Nvidia Shield and weirdly enough it picks up my remote in the menu but not the controller.

I’m also having this issue. I got it to work only once by using the Origin Steam Overlay Launcher, but after that it always fails to start, saying that the game is already running. I can assure that is not the case since I’ve done it immediately after rebooting with the same result.

This is really frustrating for me, and no amount of tinkering with controller settings in steam has helped. I’ve rven tried virtualhere for steam link, it I think that application is broken because it just crashes on my machine…

My solution which I just finally got to work was to use Origin Steam Overlay Launcher. One caveat, though, is that you will need to read and follow the notes on workarounds for the epic games launcher. That includes making sure that you use an epic games shortcut URL and making sure that OSOL isn’t running from inside your epic games “Games” directory.

Hope this helps!

2 Likes

That fixed my problem! Thank you!

Glad to hear it! I was really frustrated that I couldn’t get it to work the day that the game dropped, and it took me well over a day to figure it out. This is what we get for not waiting for it to drop on Steam in 6 months!

Thanks I can finally play on my TV!
I just have one issue left, if I bring up the Steam Overlay then get back to the game, the controller input is not working anymore (I guess the game do not have the focus because if I go on the computer and click once it fixes it), do anyone else have this issue? If not, could you share your OSOL ini file?

Thank you so much as it was driving me crazy to not be able to play this on remote play through the steam link. I can’t always play on my computer physically, so this is a nice work around!

hello, this is not working for me. it opens the epic games launcher and it says that bl3 is running. but nothing happens. the game never starts.

Hey, I found another utility that is even easier called SteamGridDB where you can even pick community tiles for in home streaming.
May need to close steam after that import and reopen and then run the steam link.

2 Likes

You sir are a F***in legend i spent so much hastle with osol to get knowhere thank you for this