Steam Store Page is out of date: MAC OS 10.7.5 no longer supported

According to the Steam Store page for Borderlands 2, the minimum Macintosh OS requirements are “10.7.5 (Lion), 10.8.5 (Mountain Lion), 10.9.5 (Mavericks), 10.10 (Yosemite)”.

However, according to Aspyr, the new update from 29 Oct 2015 renders Borderlands 2 incompatible with 10.7.5.

[quote]In a series of upcoming updates, some of our games will no longer support OS X 10.6 (Snow Leopard) or 10.7 (Lion). Affected games and game content include the following:
[…]
Borderlands 2 (updated 10/29)
Borderlands 2: Game of the Year Edition (updated 10/29)
[…]
If you are currently running OS X 10.6 or 10.7, you will no longer be able to launch and play the affected titles once the update has been installed.

In order to continue playing any of the affected titles, please follow any of the steps below.

Upgrade to the latest version of Mac OS X[/quote]

I suggest updating the Steam Store page’s MAC requirements for Borderlands 2.

Regards,

Edit: Just noticed that the recommended side has an error in it:

10.10 is Yosemite, not Mavericks (10.9)

This would be a good time to correct both this and the above requirement.

(Otherwise, btw, I think the summaries and caveats are very good and thorough.)