Still won't start

C&P my message from Steam forums here:
Hey,
I’ve searched all kinds of forums for a solution, found a lot of suggestions:
I’ve tried the following things:

Update Redistributable Packages by hand
Update Redistributable Packages with VC_RedistInstaller.exe
Update Redistributable Packages again (huge list from gearbox forum, all updates both 32 and 64 bit)
Replaced msvcp110 by hand.

DirectX updates

Update Graphic Card drivers to newest Version.
Made Profile in Nvidia crontrol Panel for HW (no integrated card anyways)

Tried the Launcher every time: nothing happens.
Tried the HomeworldRM.exe with suggested launch parameters: 0xc0000007b error

All these things done in Win 7 and Win 10 Build 10074

Current rig:
i5-3570K
8gb ram
GTX 660 Ti

Os used (64):
Win 7 Ultimate all updates
Win 10 Build 10074 all updates

Graphics Driver used on both OS:
lastest official, latest official beta.

I think i’m done -_-

Edit: no ErrorLog.txt whatsoever

As I recall that means your redist is not installed correctly. It is a pretty universal error in that regard. This is a 32bit game - so we’re looking for the 32bit libs. I bet you’ve cross-installed them somehow.

Check step #10. There’s also, under new Windows another folder besides system32, called SysWOW64.

Generally, any of the MSVC ‘redist’ files in system32 will be the 32bit ones, and those under SysWOW64 will be the 64bit ones - if you aren’t sure (and if you DL the redists, you can compare to make sure) - generally the 32bit ones are the smaller of the 2 files with the same name.

System32 is 64-bit and SysWOW64 is 32-bit.