Stuck surveyors in digistruct peak

Has anyone else had the misfortunate scenario of surveyors glitching out in digistruct peak. Twice this has happened to me today when trying for op3 with my Gunzerker, while at the end in the Assassins arena. This one surveyor left me stranded and all I could see was the red dot on the mini map to where it was outside the arena. I think I`d killed at least three of the Assassins or it could of been all four with just this nuisance surveyor left to destroy. I threw grenades and fired rocket launcher rockets over the wall trying to get a hit but alas…nothing, run out of amo, so just quit to face the grind yet again. How frustrating these peak runs are!!

I’ve had it happen both there at the Assassins and at the end of OP7 and OP8 runs before OMGWTF so I understand your frustration. Best thing that I’ve found to combat this, especially with Sal is dual Topneeas slag and shock, and try to fire them in the general vicinity of the Surveyor. If you have a Sham and Logan’s Gun (any level), you won’t have to worry about ammo issues. The AoE should be enough to take them out. I’ve also had luck with jarring those surveyors near the Assassins with a Quasar (Singularity).

The Surveyor at the end of the Peak is much more difficult to hit as it seems to get stuck further back in the wall and is much harder to damage.

It happened to me a few times, in the areas of Doc Mercy and Saturn. Sadly, there isn’t anything that can be done about it (without resorting to CheatEngine).

???

I just gave two options neither of which involved cheating.

I have tried these options myself and they don’t work in the scenarios I experienced, where surveyors get absurdly far away and/or below the map.

Thanks for the replies guys…Yes I do have a Logans Gun but Id left it at Sanctury, typical!! Anyways Ill be trying again later today so lets hope for a better run. As for a cheat engine it seems the only cheat here is the game itself for cheating me out of my op3 level. Will let you know how it goes.

Ugh. I just had this happen to me (Windows Steam version), except it wasn’t even a surveyor, but a bandit. What a waste of time. Is this rather common? Wondering if I should even bother. Makes me want to rage quit the game altogether.

Is there, like, a “noclip” console command you can use to get to the next section?

Or maybe I can just unlock the OP levels with one of those save editors (and then just do the peak runs anyway without worrying about the game robbing me of an OP level and the ensuing rage)? I’d really, really, really hate to do something like that, but this is just too much ■■■■■■■■ to bear. You don’t release a time consuming challenge like this when this kind of crap happens this often. If they can’t legitimately fix it, they should have made some sort of band-aid solution (like a switch that starts the current section over, or something). What the hell, Gearbox.

I feel your frustrations yishaijah, I have been robbed of a level on more than one occasion and the latest being my game decided to freeze and crash on me while attempting OP6 with my siren. I was so angry, and had to quit the peak for a while to regain my sanity. I`m on PC too but I do not think it matters what platform you are on, it will still happen anyway. Digistruct Peak is definitely a challenge thats why I love and hate it so much, and I will return to face the mayhem when I am in the right frame of mind.
Anyway good luck with it and the best way of looking at it…its only a game :rage:

Surveyors do this with regularity. Gbx elected to patch jumping thru the entry way, which was one way to get to glitched surveyors, as well as skipping most of the peak. Of course they never fixed the surveyor problem. I’ve lost out on a dozen runs for that reason.

I might suggest staying towards the entrance and building nearest the entrance to the area before omg and not approach the slope up tp the vending machines.

Surveyors might be less inclined to fly into the mountain side and get stuck.

They also get stuck around bone head too.

I’ve never run into this problem yet, but I can suggest regular E-tech launchers – or if you’re co-op with someone using Gaige, send out Deathtrap. The launcher generally ignores terrain, although I’m not sure about distance burnout; Deathtrap can fly through terrain and/or fire his eyebolt (or laser) from a distance with unerring accuracy.

Happened to my brother and I once. On op7, we just beat all the assassins. We couldn’t move on because one of the surveyors got stuck by a vending machine (judging by the mini-map). Also fired the norfleets, threw quasars, still had to start the whole run over. I was playing as Maya, I don’t even want to imagine what those op surveyors are like without phaselock. I always prioritized the the surveyors first, since that time it got stuck. So annoying how they fly around attacking you and regenerating themselves after you’ve killed everything. >.>

the thing about surveryors without maya is to put your back to a wall, and in coop bunch up a bit. this way the suveyor will flight right at you and you can kill them much more easily.

So…is there a reason why this bug hasn’t been fixed?! Seriously. What’s the deal Gearbox? This isn’t something that endears players to keep playing. 2019…Battle for Sanctuary…and this ridiculous bug remains. Unbelievable.

This post was flagged by the community and is temporarily hidden.

1 Like

Btw but I think they fixed it though!

When the surveyors stray too far off screen and get stuck they self-destruct! At least they did when I was playing digistruct peak earlier