System link GOTY

Having trouble linking. I am running version 1.0.9 on my BL2 and 1.0.9 on a GOTY set.

Once we select to join each other. We receive a message that claims we have different content.

Please help

We cleared the caches on both systems, multiple times. Both are running the same version, 1.0.9.

When linked, we can find each others game, select to join. The are told the versions are not compatable.

Any thought??