"Tales From The Eridian Slab" achievement didn't unlock, Galaxy Progress says I collected 37 of 30 Eridian Writings

I went through all locations one by one, all Planet Progress chart shows that I have translated all Eridian Writings, yet the corresponding achievement didn’t pop up. Then I checked the Galaxy Progress where it showed 34/30 first, but now it’s 37/30 already. See attached screenshots.


I was getting annoyed about this to but look no further go to Tannis’s lab in the ship and spam the inspect option on the big eridian slab that fixed it


Hah, it fixes it indeed! :slight_smile: It really did unlock for the third try. So now my stats says 40/30. :slight_smile:


no, didnt work for me


Same I have 40/30 and it doesn’t work. A guy on YouTube posted that he deleted his character FROM CONSOLE then reloaded the game. Hit Tannis’s slab and it worked not mine though.

Did you hit the slab more then once
I know I had to click it 6 times before the pop


Can confirm, I had to scan it like 5-6 times. Just keep going and it’ll pop!

1 Like

You legend

Edit: How’d you come across the fix? Spamming in anger?

1 Like

Wont fix it for me , I have tried a lot of times now

Worked for a friend.
Not there yet myself but I relayed him the “Spam Tanisl lab slab” trick and it finally popped.
Took a while. He melee it too. Out of despair I guess. Not sure if it did it or not.
But it did pop at some point while he was in Tannis lab.

Spamming the eridium slab in tannis’s lab worked. Thanks for the advice

1 Like

Yeah they have to fix the progress system . But spamming that tablet worked for me

1 Like

Spamming the slab in Tannis’ lab does not work for me. I have tried it numerous time. Spamming it 40 or 50 times on each try.

Same here

Ha, spamming it AFTER equalling the Galaxy 100% amount (30) works. This game is hilarious and the bugs are in line with how funny it is.