Terrible Performance on High End PCs


(Justinian84) #1

I’m seeing many initial reviews call out the poor performance on powerful systems, and there are frame rate drops in almost every video of the game I’ve seen online.

I myself am running an i7 6700, 8 GB, GTX 980 Ti Windows 10 rig and my frame rate plummets during every battle, sometimes dropping into the 35fps range. This is simply unacceptable considering this system can run Witcher 3 at Ultra settings with HairWorks at a consistent 60fps.

That said, there are some people online who claim they can run it very smoothly without frame rate drops on much weaker machines.

What level of performance is everyone seeing? Perhaps it might help the devs determine the issue and fix it.


Huge performance Issues
(abuster) #2

nah, its a general issue and must be fixed. They cant expect that every user is going to find out, how the game runs the best on his computer. its different from system to system.

This game thaught me finally: Never pre-order a game again


(Justinian84) #3

Sigh… there’s nothing more frustrating than seeing others with far inferior systems getting perfect performance while my top of the line machine chugs along.

Here’s another example of someone with a powerful rig getting terrible performance:

I think it might be time for a refund.


(Snake_B5) #4

yay, and absolutely not time to wait a little for a patch resolving the problem…
Seriously guys, the game was released only yesterday ! oO


(chrisav) #5

It works over here without any problems for 90 minutes.

i73770k, 16GB RAM, R9 290


(Not actually Jesus Christ) #6

It runs better on my 2009 Toshiba laptop than on my £1000 PC…


(Snake_B5) #7

what’s your configuration ? Nvidia also ? (I ask because a lot of the messages I saw with this problem, here and on BBI/Steam, have nvidia graphic cards)


(Not actually Jesus Christ) #8

Got an AMD card and processor…


(Influencer Guy) #9

Thanks for the feedback here, guys. Definitely passing this on to the team.


(Not actually Jesus Christ) #10

Thanks Joe! :wink:


(Snake_B5) #11

ok, that was just to know. At least, it is confirmed that it’s not a driver problem


(Justinian84) #12

Thanks for passing it on Joe. I have hopes that this can and will be resolved.


(abuster) #13

This argument is bs on so many levels…

  1. standard options/features every game have are missing (like set bindings in options and more.)
  2. standard features homeworld 1+2 have are missing (like pause game, alt center camera, building menu instead of fkn scroll to carrier and mroe.
  3. YES, the game is 24h old and most players found so much no-go things in less then 1 hour. So developers aren’t playing their own game before publishing?
  4. and how old are? are you born in the latter years, when it’s normal, that a game is published, but you cant play it and you have to wait weeks and months of development? arent you used to games, that are working quiet good and are kinda complete when released? I must be really old now, remembering games which arent in beta status when released…

(Snake_B5) #14

… if you can’t even read the premise of my answer, don’t even bother. We were specifically talking about the performance problem, not anything else.
And I’m from 1980, thank you. Must I remember you that even games from the 90’s had problems when released ? C&C, HW1, Total Annihilation, etc…, all of them, without exception, had post-release patchs at the time.
Nowaday’s games are a lot more complicated code-wise than they were at that time, and the probability of bugs is directly related to that. That’s not to say that it’s an excuse for those bugs (clearly not), but hoping for a totally bug-free game one day after release is not sensible at all.


(abuster) #15

yea, i know it was just about the performance problem… and I agree, its one of the points that is acceptable, but still its one point of a whole list, its not like: “Okay, they brought a really good game and now they have to tweak some things for the perfomance” - it’s “no surprise, that performance sucks too, after alot of basics are missing”.


(Watcher on the wall) #16

Ok guys. Lets not start with the personal jabs. When things start taking that turn, things usually start snowballing.

Keep things excellent.


(Not actually Jesus Christ) #17

Meow. :smile_cat:


But on topic, this is a problem that is sure to be fixed by BBI, the team did make tho Original Homeworld! :wink:


(Snake_B5) #18

No problem on my side, my post was only to point out the original reason of my first observation.


(Bee) #19

I7 4790K @ 4,8 // 2 x 8GB Dominator Platinum 2400 // Asus Strix GTX 980ti // DOK installed on Samsung Pro 500GB SSD. Running the game at 1920x1080 with all settings at max. No probs at all.


(Drahkas) #20

I’m running an i7-6700 with 16BG RAM and a geforce 770 with all graphics setting maxed. Obviously the graphics card would be my bottleneck but I have only noticed slowdown twice(for about 5 seconds each) in the past 10 hours of play.