The Saboteur (and some general) complaints

We all think bad things about The Saboteur. It’s terribly optimized - some geometry/FX/whatever nVidia crap makes it’s average framerate oscillating around 35-12 frames per second. But there’s more, and I’ve experienced that [before the] last time I played it. I’ll illustrate my observations with a gameplay footage.

  1. Cue for action stops before actual action stops. Wasn’t that suppose to be fixed with last update?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=2m45s
  2. Do you see what I see ti “Evolved Thrall totem”? WTF?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=4m17s
  3. Thrall Brute “phasing” through door.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=5m0s
  4. What the hell is wrong with characters stucking in doorways?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=8m15s
  5. Players constantly fall down because of framerate issues.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=8m44s
  6. Fun fact: door to this stash location open after the battle - wonder how one would use it (one who can’t hover, fly, long-jump). By respawning?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=8m48s
  7. Notice how Caldarius’ charge stops on nothing, in the middle of a ramp.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=9m04s
  8. Now nitpicking. The challenge: how is that there’s not enough Varelsi around to comlete it (idle red dot is probably a missing Varelsi, btw probably stuck in a geometry- observe this from time to time).
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=9m39s

BTW There are many actual challenges’ issues on many missions, like The Algorithm, where challenge to eliminate numerous Spawners show up when there is actually only a few/no Spawners left to kill. Or The Archive, pickups challenge, when there’s virtually no pickups left around…

  1. Or The Saboteur again - the one for picking up some shards, when there are not enough shards around left. What, I should fly up somehow to reach the upper platform shards?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=14m27s
    10.Notice persistent Varelisi scaven alpha debuff visualization showing up out of nowhere - I had missions where it persisted even till the very end of a mission!
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=18m16s
  2. There’re a persistent Varelsi slow-down field ocurrences. Also: it could not be Varelsi Maligner that casted it - then who did?
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=20m47s
    12.What’s with the space between pipes- my character should be able to pass it.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=21m24s
  3. It’s rather doubtful that some puny Summoned Thrall and a Brute were able to deal with that duo - probably another framerate issues.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=22m20s
  4. Funny how Bonecrushers shockwave goes down the stairs while Caldarius’ charge stops at any random bullshitty edge piece.
    https://www.youtube.com/watch?v=vgqqGY4QqQ4&t=23m08s

Did I miss something, doing something wrong? What’ll support do with this?

Just a heads up, all of these videos appear to be on private. I can’t see any of them lol.

There is another spot that a large chest can appear - down some stairs in the bottom of the very next area. Was playing last night and grabbed the one from the upper platform (Kleese can fly - just!) and the lower one wasn’t there, but other times when no-one has gone up top it has been. Makes me wonder if it’s random, or if the game actually moves it?

Fixed that. Thanks for notification.

1 Like

Okay so first off, good eye on a lot of these. Rhem, good characters terse and helix choices. Third, there are some secret areas that you can only get with certain characters (and that I never even knew about that area, even after running it so often. I’ve had the infinite slows and pink effects many times
And some of the characters problems is just Kleese’s huge model.

Well, I’m glad I’m not the only one with such problems (a bit, like a relief, it’s not funny I mean).
Today I launched The Saboteur in singleplayer on fresh instance of Windows 8.1, and didn’t have these …but had another one - a Thrall sunk into the floor and it sunked into one of closed rooms in first “control room”.


Lucky for me I played Marquis who, more lucky me, was able to shoot Thrall through one of tiny spaces between bypass doors pieces. Wonder what I’ll discover next.
That time I also checek more cautiously mentioned above space between pipes, and ■■■■ robo was able to pas it, though at straight angle not the sharp one like on the footage.

PS Also then was able to reach said loot spot, just needed to make a precise jump from one specific place. Though it still does not explain why, why would door leading there from a duct open after the fight in first control room.

PPS @VaultHunter101
During my last The Saboteur run I also noticed some displacements in loot cases’ locations, bet that’s what you say - RNG places them on a map.

1 Like

The physics of the underlying game engine can be a bit, er, Unreal, as I’ve noted before…

I’ve had the same thing happen at the sub-station in Renegade a couple of times, and at the elevator shaft in Sentinel at least once. Fortunately, waves are also on a timer, so if you can’t kill the stuck enemy you just have to wait out the timer. This can seem to take forever, but I’m pretty sure it’s never really been more than 2-3 minutes tops.

LOL the sabatour has far more problems than just frame rate. I will say it’s gotten better since they fixed the difficulty. I’ld beaten it before the nerf and it’s still pretty challenging.

Heh, I’m in constant contact with support, and today I was trying some tips they gave me on how to improve my Framerate. Trying on The Saboteur of course. And I get another facepalm challenge


Are two enemies enough to score 1000 points? :wink:

Also earlier had some kind of bug where I activated all of my gear and game would still pop up info on last piece being able to be activated - which I can not activate once more of course.

At least I gained average 5 fps better framerate…with all of non-windows services and antivirus turned off, setting up my OS on SSD and all video settings to minimum. Barely playable, but playable.

OK, so the title is about general complaints too, so I got one.

I don’t know how long ago I heard about The Experiment and Boldur’s script glitch at the beginning of a mission…and it’s still there: after initial introduction and 2 fights guy is standing there, or the stairs above, waiting for something or watching something, and has to be pushed back to a “meeting place” before he can move his kilted ass to actual experiment site. And it isn’t hard to notice since it occurs 9 out of 10 times I play it.
Realy, 2 months after the premiere and it wasn’t corrected yet?!

That’s weird - I have never ever run into that, and I’ve played Experiment many many times. Do you storm the initial wave as a group and ignore all the collectibles there?

There’s still the audio bug that happens every time (for me) though: Melka’s line always plays twice. ("Hope? You mean you don’t know if it will work? "Hope? You mean you don’t know if it will work?)

Same here - Melka’s line plays twice.
As I wrote, Boldur’s script bug is a good old problem known for long -ppl were talking about it to me for long- and pretty regular. Actually, can’t remember when I HAVEN’T seen it. Boldur does IT whether he’s bothered or left alone, it looks like this

Also, today I’ve met another tiresome bug, at The Archive for a change: my Brenedict tried to perch on Chronicle’s Shard Bank (U know, birds ;)). And got stuck - no double jump nor Liftoff could send that bird back in the air. Had to reconnect, and when I was back there was not much to put together of my team.

And also, remembering other quite old, not sure but might seen’em back in Open Beta, set of bugs in The Algorithm. These are some kind of collision system anomalies during final boss fight (ISIC), and look like this



PS Going to reinstall the game, to see if it’ll manage to get rid of some of these.

OK, so I spent 1h re-installing the whole gama and downloading updates.
Today I ran The Sentinel…and however there was no famous immortal Sentinel glith -which was largelly discussed in this topic


because team destroyed Shard Crystals even before he could actually reach their jump distance, I met the same gear issue I mentioned above, only worse: this time it wasn’t only that for a long time activated gear piece suddenly ended up marked as “to be actived”, after third piece of gear activation I got all pieces marked as inactive


Also: during first boss fight I’ve noticed that my Galilea’s corruption would stuck at a third level and would not rise above despite me packing a lot of hits in boss’ butt.

Guess all that re-installation was for nothing.

OK, this game now really plays on my nerves:
today I played this new Ekunar spotlight event, on The Experiment. 2 players coop. And everything was going according to plan, destroying last varelsi wave at the end. …and then my Benedict did heroical dive attack on some hunters, and I got stuck in geometry. Mission failed.
Here’s that "moment of fail"


Also: notice that Vyn’s Quiver legendary (weared in movie) is glitched on Benedict - no bonus healing for reload, at all.

Back with more interesting bugs.
Today me and some three randoms tried to do The Sentinel on Hardcore Spotlight. After some trouble at the beginning (as usual when I play melee battleborn) when we lost one guy all was going smooth. Until the final boss fight when we had an issue with…what elese, Sentinel’s healing platform. This time I warned my comerades to wait with Crystal clusters destruction, so it was a problem with picking up fallen [down] buddies.


To put it simply: if battleborn fall to his death from the cliff where said healing platforms are their dying bodies won’t come back upstairs, so they can’t be rescued. Also: notice how our Caldy won’t just simply move down with the platform he’s standing on, but “hover” some time and then just die instead.

I’ve seen that heppen with a melee character before. If you don’t get back off the healing platform fast enough you can’t get over the gap (unless you have some sort of in-air boost like Calderius), and then as noted in the video there’s no way for anyone to revive you. That video link should go in a support ticket if you haven’t already done so, please and thank you!

1 Like

OK
Today got some Story mode mission on The Experiment (Normal difficulty, helping noobs), and recorded some more bugs- apparently new ones since there was an Update lately and I’ve never seen those before.
First is (again apparently) enemy spawner error, as game gave me this


as soon as I encountered final boss (Conservator). Seems like Mission:Impossible to me, or a job for Doctor Who (this backwards going timer ;))
But that doesn’t end here, even more hilarious was Mission Summary

Negative Team score? Paraphrasing one of the Battleborne “Meh. That’s interesting.”

Newest issues with Battleborn? After the famous October Update? Is it possible?
Yup, pretty much. Pretty much anything that “patch” announced concerning performance is not true: I meet no performance improvement on Outskirts, nor on Echelon. That’s one.
And two, there are actually new issues coming with that one, and still not corrected: as I was playing single player Story Mode on The Algorithm (as orendi) I suffered random framerate drops during action, More over, the final boss fight with ISIC was …going in quite the right direction, until the flying head stage where

  1. I wasn’t actually seeing the head attacking me, seems like it was glued to top of Orendi’s head
  2. At the end I was launch by this “head” far far away beyond level geometry.

This happened to just after said update when I was playing The Heliophage as Oscar Mike too. There’s definitely a new problem with collisions in Story Mode.

Being launched out of the arena isn’t a new thing, though - it’s been reported pretty much since launch. Admittedly, it doesn’t happen all the time (I’ve never experienced or seen it in any match I’ve played, for example) so this might explain why you personally have not seen it before. It’s been a possibility for a while, though.

All right
There hase been some updates and promisses about bug fixes since the last time I posted in this thread, and I got some Update too.

Case no 1 AKA A rerun
While PvE’ing yesterday with 3 other ppl, on The Sentinel, we experienced guess what?
Yup, got it, good’ol Sentinel’s glitch. It wasn’t fixed, at least not completely. And its conditions are similar - crush all of his regen shards before he puts his feet on their platform and he’ll get stuck, in his invincible state. And even worse: the man’s hitbox was so big we coludn’t get past him - pursuant to the new collisions, characters repulse eachother.


My understanding of fixes that have been done so far is that healing shards platforms don’t descend after shards elimination now: this suppose to prevent both Sentinel’s glitching and players’ revive bug (mentioned above).
This is official: it did not work.

Case no 2
Isn’t that great about some of those spiky crushing platforms (The Sentinel) that players dying under them are not moved out of their way so team could actually revive’em?
You know, like it suppose to be.


Last night we had to revive my colleague like 4 times before he could eventually evade incoming crush (timing I guess).

Case no 3
Also on yesterday’s Sentinel run met those wonderfully compliant Evolved thralls.


Aren’t these cute?