There is a dx12 fix?

Today i tried again to use dx12 instead of 11 and the game won’t launch at all, just a crap ton of “unknown” errors…
There is a fix for that today?
The very first time i tried it, the loading times were super long, never tried again since.
Im on a rx590, ryzen 5 3600 and 16gb 3200mhz ram.

Do you have the correct up-to-date drivers installed?

https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-590

There’s a temp folder somewhere where the game writes while initializing shaders etc during the claptrap loading sequence. If the game is crashing when it hits that part of the load sequence, you may need to nuke the contents of the folder before launching the game.

Im using the latest driver from radeon software, the game crashes after the initial logo with the four vault hunters, the game doesn’t have the chance to show me claptrap, after this logo there is a crash popup (not the unreal one, just a windows pop up that say error unknow for various of times in a row.
That’s it

You might need to file a support ticket then. A couple of things you can try:

  • Delete or move the existing config file and relaunch the game - there may be some odd settings conflict. Note that DX12 is now the default, so that should be enabled with a brand new config file

  • Verify files, using the option through your steam or epic library

(Chances are support will ask you to try those things anyway)

thanks ill try this as well, ill tell you if it works

Well your using a RX590! Id assume the RX590 is low end! Have you tried maybe upgrading to a 5700XT! Your issue might be the GPU is too old. I had a RTX 2070 an never had a DX12 issue! Maybe like two crashes but, It ran stable for me.

Maybe its time to upgrade! The 3070 is $499 which is better priced than last year when the 2070 came out. Im sure if you go with either the 5700XT or RTX 3070 your issue would resolve itself pretty quick.

You should also upgrade that processor to a Ryzen 5 3600X or Ryzen 7 3700X! I hear the X series is really good! I also heard that 3200MHz is kinda low! I recommend 3600Mhz Dual or Quad sense BL3 is pretty damanding. If you are using motherboard that has ram slots open. I suggest filling them spacing out your chips. Never load everything on one chip. It definitely degrades performace.

it’s 1 or 2 year old, betterish than a 1070, no problems at all running bl3 at ultra or any game even with volumetric fog at 90+ fps really…

The ryzen 5 3600 x is not worth the money at all, it’s the same as the 3600 with a slightly higher clocks that i can achieve by activate the automatic oc from bios.
If i will even upgrade the cpu, i will buy the new 4000 ryzens, but i will keep this bad boy for years to come, no need to upgrade it at all.

I will buy the next amd big navy if cheaper than the 3080.
Regards of dx12 the rx590 is totally compatible, is just i have problems only with borderlands 3, itbworked at first now i have problems with the game only with dx12, which in all fairness is not a big improvement over dx11, mayyyybe i will get 10 more fps but i play with capped 60 or 75 fps depends if i remember to change it.

My ram of choice use the ryzen infinity fabric efficiently, upgrading the ram is totally pointless in that regard, i will get 1 or 2 fps more for 200 euro to buy a 3600mhz cl15 ram sticks.

dont compare an rx590 with a gtx 1070 please :smiley: had a rx580 myself before. lets say lower mid end. but it shouldnt have issues with dx12. and if im not mistaken i red that some 5700xt and nvidia users also have dx12 issues

hadnt have a dx12 issue so far. only one time? in flood basin the textures where a bit weird.

gtx1070
2700x

I have both cards in two different rigs, pretty much the performance are the same, in some games the rx590 does way better than the 1070,same for the 1070,pretty much the rx590 shine in all amd optimized games such as borderlands 3.
But the difference between the two are just a mere 5/10 fps at most,both maintain 60 fps every where a part total war warhammer 2, three kingdoms and fallout 76.
(i have the latest rx590, the gold anniversary edition)
On my end, on borderlands 3 i never had a problem or a fps drop, the only time i had one was on sanctuary by running, dropped to 40 fps. Problem fixed pretty fast with patches (dx11)

Just as a follow up, there’s a whole thread about a recent error that’s been cropping up for both BL2 and BL3. In this case, it looks like unlinking and relinking your shift and steam/epic account via the website might clear whatever the issue is. Not sure if that’s the same error you’re seeing, but it might be worth a look.

1 Like

Hi there some greatish news,
So the good news:
I managed to make it work on dx12 by changing the location of the game, verify file and delete all configs.
Gained 40ish fps in most places(always 60+ fps even before) but this time on badass settings and medium volumetric fog.
Bad news :
I’ve changed the game from a ssd to a hdd a good one but still… i gained like 2 seconds of load time i guesd… so not big of a deal, can continue farming(liads pretty fast the maps, only when starting the game takes a bit longer)

So when you said you changed the location, you mean you moved it to a different drive?

yes, but now if i want to play on dx12 i have to delete the config file every time… if i restart the game i will have the previous error
" the ue4 oakgame game has crashed and will close"
low level fatal error blablabla and a bunch of 0xc000000 errors like i have some net framework /redistributables errors but if was that the problem no games on my computer should work at all and neither borderlands 3 at dx11 or dx12… well ill keep to delete the config before starting, just a two click fix

Sounds really weird, like it’s looking for the config file in the wrong place or reading some corrupt garbage from somewhere. :man_shrugging:

very strange indeed

From a related thread:

That might be worth nuking to see if it prevents you having to continually delete the config file?

1 Like