Tiny Tina DLC advice

I’m sure this has been asked quite a few times so I apologize for any annoyances. I’ve done everything solo, as far as I know I’ve done all the side missions up to this point. I’m on the ‘A Game of Games’ mission. And the objectives are Reach Dragon Keep and Free the Queen. Every single time I get to the bridge where you’re supposed to fight the Dragon I get the ‘All Players Needed’ message. I’ve looked it up and I’ve tried everything from changing my network to offline to exiting the area and coming back to resetting the game. I’ve even gone as far as to hard reset my Xbox. Nothing seems to work. Is there something I’m missing? Something I haven’t done? Or am I just screwed. I can’t figure out what’s wrong.

I know this is kind of a weird question, but how far into the bridge do you go?

From the drop down all the way to the other side where the waypoint leads. I was looting all the chests along the bridge the first time I noticed it happening.

Sounds a bit odd. Did you ever get a cut scene or a Handsome Sorcerer dialogue when you dropped down and went out onto the bridge? Is Roland out there with you?

That is weird indeed. That map is a little buggy for me in a few places that require suicide to get through, although it has never happened there for me before. Have you tried taking a nose dive off the bridge to reload from the save point? Sometimes that will trigger the cut scene to continue if it is not coming up.

Don’t suppose someone on your friends list joined your game w/o you noticing? Or maybe you had a second controller active and hit the join button by accident?

I had this happen to me once when I was playing solo. All I could do was to save and quit, and do the fight again. :unamused: