[TOOL] DAEnerys - DAE Ship Editor


(ajlsunrise) #502

@PayDay Yeah, your edits to the shaders, turning it into an array of all files contained in the datapaths screwed with the shader loading. When it attempts to import sob_ship.frag referenced by the .prog (really sob_ship_share.imp), it adds the code twice (because of the two data-paths it found shaders in).

@Nathanius (@Payday): Deleting the offending sob_ship.frag from the STCR data folder solved the issue for DAEnerys. Shouldn’t affect the game, though.


Like I said, I’ll bump the shader loading issues to the top of my free-time plate this week.


(Nathanius) #503

Is the sob_ship.frag identical to the default one? Hmm, I’ll review what I have and delete what’s unnecessary from the shader folder. A copy and paste from the default set over the top is all I need for Tortoise SVN to tell me if and where a difference is :wink:

Glad I could… help? I think I helped :thinking:

//edit
This was the difference in my sob_ship.frag:

Fixing that disabled glow that was mentioned somewhere here :stuck_out_tongue:


(ajlsunrise) #504

That I mentioned, for asteroids! :slight_smile:


(ajlsunrise) #505

Well…

I broke the shaders… again…

Would you believe this is actually progress though?


(ajlsunrise) #506

Progress???


(Nathanius) #507

Hiigarans to the discothèque? :sunglasses:


(ajlsunrise) #508

Fixed:

Turns out it was working correctly, I had just forgot I had put the calculated glowmap as the diffuse texture because of the earlier problem.


@PayDay: Changes have been pushed to the repo.


(Christoph Timmermann) #509

Thanks for the work radar! Looks great so far, but I get a StreamWriterBufferedDataLost-Exception when closing DAEnerys?

Ohh, how long did you sit on that mistake? :smile:


(ajlsunrise) #510

Re: SteamWriterBufferedDataLost, is that just in the IDE, or does it occur outside of the IDE too? I’ll track it down eventually… :confused:

A bit. I also had another bug I was stomping on first, before I got to that…


(Christoph Timmermann) #511

Ahh… only in the IDE, it is the manifest.log stream writer. Probably doesn’t get closed correctly.

EDIT: Make sure that you don’t block these kinds of exceptions in your IDE settings.


(ajlsunrise) #512

I don’t, I’ve just been ignoring it :sweat_smile:


(ajlsunrise) #513

SteamWriterBufferedDataLost exception has (hopefully) been nuked.


(Pbobbert) #514

@radar3301

As directed I am replying about my crash issue for v6800. Trying to launch the application will show the hour glass for a second then gone. I can see the program in task manager for that duration, then it quits. No manifest.log is ever created, and log.txt is empty.

I just tried a previous version v6746 and it appears to work just fine. I havnt explored any of it yet so all I can saw is it opens my ,blend and shows the mesh and texture just fine.


(ajlsunrise) #515

Are you running 64- bit or 32- bit windows?


(Pbobbert) #516

64 bit windows 10 everything is up to date


(ajlsunrise) #517

Do you have a settings.xml file?


(Pbobbert) #518

Neither of them have a settings.xml file.

That said I believe I have figured out the problem. If you view the attached screenshot, notice the two highlighted files. v6800 does not come with these. Upon copying them into the directory from v6746 the application launches seemingly correctly.


(Pbobbert) #519

I found a bug in v6800, dont know if its cause of my janky solution to make the program running.

When trying to add a joint using the add template button, the window that pops up appears cut off as seen in the attachment.

I cannot say for certain, but I believe there are two buttons, cancel and ok. You can use the TAB button to cycle to them for now. If you click the enter name box and press tab 3 times followed by return, you will create the template.

I have also noticed some visual bugs such as the hotkeys window, most of the entries have the bottom cut off.


(ajlsunrise) #520

What is your screen resolution?


(Christoph Timmermann) #521

Ahhh, another 4K user. :smile:
Sorry for the inconvenience, it’s always a bit wonky with the DPI-scaling. Thanks for the bug reports.
It will be fixed in the next update.

3840x2160 I guess.