[TOOL] PayDay's Map Editor


(B8factor) #81

I would say some objectives like Pebbles, Asteroids, and ships do not have a need to be within themselves, so objects like that can be a simple layer that is either (show them) or (don’t show them).

However, Volumes… and sometimes even dust clouds or nebula’s, DO often overlap. In a case like this I would use metadata that the editor handles but the actual LEVEL file knows nothing about.

e.g.
the LEVEL file has this:

addSphere(“SphereVOL_17”, {-13922.75, 5133.317, -34000.16}, 100)
addSphere(“SphereVOL_18”, {-13293.22, 4500.942, -34500.16}, 100)
addSphere(“SphereVOL_19”, {-14500.96, 6000.718, 9000.165}, 100)

but a meta data file in the tool directory has something simple like:

|addsphere|SphereVOL_17|0|

As in, when opening this level if there is a addsphere of SphereVOL_17, do not show it in the editor because the FLAG is set to 0(off). basicaly the tool would filter what it shows on teh screen when reading the LEVEL file based on a metadata file/config file/text file the editor itself created when the user checked(in examples below as check box) not to show a specific object.

Of course the tool itself would need a UI to allow checking or unchecking of objects to be visible. Jut off the top of my mind, while at work here is the UI from VISIO to show or hide objects.

I can toggle if the user sees green line, red dashed line, or both.


(B8factor) #82

Sometimes a picture is worth a 1000 words.


(ajlsunrise) #83

Did you take that idea from me? :stuck_out_tongue:

I was actually thinking about this, and my thought was that we have 2 file formats, the Homeworld .level file, and a MapEditor .map file that you can save that sort of information into, and an "Export to Homeworld .level" button.


(Christoph Timmermann) #84

I saw your FXTool property grid after I implemented it. :smile:

Sounds like another good idea.


(B8factor) #85

That is what i meant by a meta data file. A file that is just for extra information that is not part of the real LEVEL file… aka meta.


(Taiidan Republic Mod) #86

I think the idea of doing layers by comment lines in the level file sounds cleaner to me.


(B8factor) #87

Either way it is implemented works for me. And even if it is not, I still love using the tool. :slight_smile: Wanted this for so long… can not say enough about it.


(Taiidan Republic Mod) #88

Haha, your tool found an error in the HWRM stock files:

I guess no-one else had asteroid0.resource in their data paths when they tried this…

This is the line that causes the problem:

NewResourceType.CollisionFamily="Small"ll"

Should be

NewResourceType.CollisionFamily="Small"

The last few characters in asteroid0-5.resource all have similar issues.


(ajlsunrise) #89

That’s actually just you. I just checked those files, and none of them are like that.


(Taiidan Republic Mod) #90

I did wonder if it was an error during extraction from the big file…


#91

Other than obfuscation, why would you have two file formats? Anything you need, you can store in the .level file.


(Sastrei) #92

The idea being that the new file format could be as rich as you want for the benefit of the map maker, I think.


(ajlsunrise) #93

This. Keeps the level file non-cluttered. But PayDay may have already worked around this one. I’m not actually involved in the map editor, like I am DAEnerys.


#94

There’s no limit on how rich the .level file can be, other than artificially or self-imposed limitations.


(Eville Jedi) #95

I have an issue with the tool that it won’t display the map window information unless I click, when I release the mouse button it turns black again. It is adding items and respects the keyboard commands, just won’t display data without clicking. Other tools like Daenyrys work perfectly fine

Radeon 7850 newest drivers (updating did nothing to improve the situation), win 10 x64

No crashes, logs or problems


(Christoph Timmermann) #96

What do you mean by that? The 3D view?
Did it work in the past?


(Taiidan Republic Mod) #97

It works fine for me, but I keep making selection boxes whilst rotating the view, which is not ideal…


(Eville Jedi) #98

The 3d view is black unless I click inside it and hold down the mouse button. This is the first version of this tool I have tried and I don’t have previous versions (though right now the bitbucket link is 404) current versions of Daenerys and the FXtool both work fine (assuming there hasn’t been significant changes to the rendering code)


(Christoph Timmermann) #99

How is that? Left-click and dragging makes selection boxes, right-click and dragging rotates the camera.

There is only that single version of the map editor available yet. I have no idea what would cause this, maybe the new version (that I have but isn’t released due to polishing work that needs to be done) fixes that.


(Taiidan Republic Mod) #100

For me mouse button 1 rotates the camera and makes a selection box. It may be because I have my mouse buttons reversed (have you hard coded right mouse button for the camera but used primary mouse button for the selection boxes?)