[TOOL] PayDay's Map Editor


(Flamm1ngdem0n) #121

I downloaded another copy from the OP within the last 2 days and I still get the error. So I don’t think any of the files are outdated or “bad”.


(ajlsunrise) #122

When you get the Assimp32.dll error, click on details and post those here.

What version of Windows are you running? And is it 32 or 64 bit?

What version of the .NET Framework do you have installed? You can follow the instructions here:
https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed#net_a
If you don’t have at least version 3.5, you’ll need to download this:
http://www.microsoft.com/en-us/download/details.aspx?id=21


(Flamm1ngdem0n) #123

These are the versions showing as installed within Regedit.
2018-05-24_0022

Running Windows 10 64bit. Also I don’t think it would affect it but in case I am running a AMD GPU and not a nVidia GPU.


(Flamm1ngdem0n) #124

Also the file you linked to download doesn’t work. Downloaded it twice. Both times I double click it and nothing. There is a split second that my mouse cursor changes from the pointer to the hourglass but that’s all I notice.

Also tried running it in Admin Privileges but it changes nothing. Not sure what’s going on.


(Is this thing on?) #125

Check that Windows Defender is not interfering with the downloads or preventing things from running. You may want to exclude your games folder from Windows Defender, as it’s caused a few problems with other titles recently.


(Flamm1ngdem0n) #126

I don’t use Defender actually. It’s disabled manually.

And the other file that was linked previously ran fine (this one: https://www.microsoft.com/en-us/download/confirmation.aspx?id=30679)


(ajlsunrise) #127

The file i most recently linked was for the .NET 3.5 installer. But you already have it installed, so I’m not surprised it didn’t do anything.


(Flamm1ngdem0n) #128

Okay. Then what am I supposed to do to fix this problem? Or should I just wait for the creator to reply at this point?


(ajlsunrise) #129

I know this might sound like a really stupid question, but did you make sure to run the installer I linked to in the first post in administrative mode?

Also, can you launch the DAEnerys tool, or does that crash for you as well?


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #130

I’m also having this issue. Can someone please tell me how to fix this?


(WildHeart|GENESIS|) #131

I’ve been getting somewhat of a weird bug where the 3D view remains a pitch black, even though all assets loaded fine. I could click anywhere and it’d procure the asteroid/pebble/whatever data was at that spot, but I can’t “see” it or anything.
I’m using a 64-bit win7 if that helps. Maybe a missing .dll?


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #132

This is the same issue that I have.


(Christoph Timmermann) #133

@herobrine101902

Did you correctly set up your data paths?
It should point to the keeper.txt in the directory that looks somewhat like this:

image

Be sure to extract all necessary files from the .big archives.


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #134

Could you show me on how my data paths should look like?


(ajlsunrise) #135

It all depends on where you extracted the .big archive to.

My personal setup looks (similar) to this:

But if you’re talking actually in the program:


(WildHeart|GENESIS|) #136

Got some more time so giving this a shot again, I’ll do over my issue in detail this time:
For starters, yes. Everything has been correctly set up to my knowledge, I have extracted the files from the following .big files: Homeworld2.big,HWBackgrounds.big,HW1 and HW2Ships.big,HW1 and HW2Campaign.big.
And placed these in a “TEST” folder along with keeper.txt, using the path you see below:
*\Steam\steamapps\common\Homeworld\HomeworldRM\Data\TEST

I’ve set the keeper.txt location in your map editor, reloaded it, but the issue persists. All that appears is a black screen, regardless of map loaded, selected background, or even a newly created map.
Holding down and dragging the mouse over the screen will produce white boxes; clicking the mouse will produce white flashes, in-between which you can sometimes briefly see what I presume to be the outline of the map (red). Two red diagonal lines will also appear if I click in the middle of the screen, but moving the cursor or doing anything will reset it so the previous state.

I have uploaded a .webm of what it looks like for me here. This is what it looks like when I try to click places, drag-select, or pretty much do anything: https://webm.red/ZjK5

My OS is a 64-bit Win7 Ultimate SP1 edition. Would it possible to do a check on your end and see what .dll files are accessed by this program? Maybe I can download these (if they are missing) or download updated versions.

Thank you.


(ajlsunrise) #137

@reylandaz
Does DAEnerys also give you fits like this? If not, you’ll probably need to redownload the Map Editor.

From the “red X” problem you’re describing, it sounds like the device rendering context isn’t initializing correctly (an OpenGL issue).

Also, any log or error files that are in the directory would be helpful as well.


(WildHeart|GENESIS|) #138

Thanks for getting back so quickly.
DAEnerys seems to be the same story from what I can tell. I re-downloaded the latest version of PD’s Map Editor shortly before my previous post, but unfortunately to no avail.

The map editor itself appears run fine (no crashes or freezes), and the .log file only has “Initializing…Renderer initialized.” for content. But there just seems to be something on my and herobrine101902’s end (assuming the issue still persists for him too?) that causes this glitch.

/edit: Managed to take a snap of the view I get for about 0.2seconds if I click on the black “void” that fills the screen (the state it returns to after this image has faded again)


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #139

Yes, that sounds exactly like my issue.


(Christoph Timmermann) #140

@reylandaz
@herobrine101902
What are your GPUs?
Supported OpenGL versions (core profile)?
Does HWRM run on your system?