TPS disc read error


(Dark Mage) #1

I came home last night and my xbox 360 elite started telling me in a pop up when I tried to launch the game that the disc is unreadable. I followed the instructions to clean the disc, restart the system and it still says the disc is unreadable. I kept trying and eventually it worked but after I exited out of the game and tried to go back in disc read error again!

Other games work in the system just fine (I tried borderlands 2 just to see). All I can tell you is I cleared the cache which didn’t help. I don’t see a picture of the game on my dashboard just the play disc icon. When I look at the “game” under details the xbox states its TPS. I also have the game installed on my hard drive.

As of today the game works. I tried it a couple times just now and everything seems to be working. Since there is nothing here about this I figured I would leave this here. I am concerned this may happen again and if it does how can I deal with it??

How can I fix this the next time it happens???


Unreadable disc
(The Bonerfart) #2

I owned a xbox360 for years and it would do this exact same thing, seemingly randomly with any game, it sometimes just seems to refuse to play certain games but would always fix itself…

If anyone has a solid answer why this happens it would also be interested to know…


(Is this thing on?) #3

It’s happened to me with different games over the years (black 360 with the 160 MB drive). Sometimes, simply taking the disk out and re-seating it in the tray fixed the problem.

On several occasions, it’s been an actual disk issue: the tabs that hold the disk in the case are sometimes very tight, making it difficult to remove the disk without bending it. This leads to fine cracks which can cause disk-read errors; if they get bad enough, the disk actually splits. I’ve also had a couple of disks where the layers delaminated around the central hole. Replacing the disk was the only option. Since the key information about the disk is in the region closest to the spindle hole, these problems tend to show up when mounting the disk in the system.

The other thing that can happen is a build-up of crud on the drive belt and pulley wheels for the drive tray. This can prevent the tray either from opening in the first place, or from closing fully. If you’ve ever ended up tapping the top of your XBox to get it to open/close properly, that’s likely the cause. It’s relatively easy to fix without console surgery, but this problem would occur with any game disk.

Otherwise, just random fluff getting into the optical path I guess. If you take a look over on ifixit.com at the complete teardown, you can see just how dirty the insides of these things can become over time.