Turn off PhysX completely?

I’ve played this game back in 2012 when it has been released and again in 2014. Both times PhysX option was greyed out in options and i was unable to change it. Now i installed the game again hoping to play with my friends, but this time PhysX option isn’t greyed out and perfomance is far worse. I tried to google and found numerous threads were people would say that it’s impossible but i know for a fact that this is incorrect - now that i’m able to change it, even with “low” setting enabled there’s a noticeble increase in detail: shooting directly into the ground causing a lot of dust and particles to appear; wind is causing cloth scattered around locations to move, bullymongs’ piles burst into many pieces when you interact with them, enemies’ bodies behave differently(i think) when you kill them, etc. It hasn’t happened before.


This is what i’m talking about - when i played this game two years ago cloth in the Sancturay was still, now it’s moving and by just looking at it i’m getting 10-15 fps drops

I’ve got an AMD HD 6670 GPU. From what i understand non-Nvidia cards can’t process PhysX so instead my CPU doing all the work. It’s quite terrible for gaming(Core 2 Quad Q6600), so i guess this is the reason for such a heavy lag.

PhysX is the name of the library provided by Nvidia to do physical computations on your graphics card (provided it’s a compatible Nvidia card); it also comes with a software implementation (i.e. running on your CPU) for all other cases (older Nvidia cards, AMD/Intel GPUs). I guess the fact that it was completely off at first on your game was a bug, that has since been solved and now, indeed, your CPU picks up the slack.

Apart from trying to free up some CPU resources, I don’t see a way for you to reduce the lag; although ancient, your CPU should be up to the task. I would recommend a thorough cleaning of your OS, updating graphics drivers before anything else. Also, make sure you’re using a 64-bit edition of Windows if you have 4Gb of RAM installed: while the game is compatible with 32-bit versions of Windows, you’re actually tying up to 800Mb of RAM for addressing reasons that would be freed if you switched to 64-bit. That would also result in the OS tasks running in 64-bit mode, in which the Core2 is 15% more efficient in average, freeing up some resources for the game. If you’re running a 32-bit version of Windows (considering the age of your system, it’s likely), please know that Vista and up allow you to use the same license key for both the 32-bit and 64-bit edition of your Windows version. If you have Win7, you may also consider switching to Win10 for free which is also a bit lighter in system resources. After that, you’ll have a spanking new system: reinstall the game and check.

Now that we’ve made sure your software environment is clean, you may want to check your RAM timings, frequency and channel mode (since the memory controller is still on your mainboard, your CPU is very sensitive to memory frequency, FSB and memory bus widths). One “gotcha!” that hit many Core owners at the time is when adding memory without using paired RAM sticks or checking mainboard RAM sockets pairing is that by adding more RAM carelessly they actually hit a 20-25% performance penalty by disabling Dual Channel. Make sure your RAM is fast and feeds your CPU as best it can and check again.

After that, it’s “tinker with config files” time! This will impact visual quality and may destabilize your game, but it allowed me to run the game in 1080p on a puny mobile i5 4200 (dual core with low frequency) with integrated graphics. This allows you to reduce PhysX effects a lot, but There Be Dragons. Head to the Borderlands 2 wikia for a more in-depth explanation of some of the file settings and where it’s located.