[Tutorial] Getting started with Borderlands Modding (Only on PC)


(Dopefiend) #1

Overview

In this tutorial you will learn how to play custom content and enable the level editor with step by step instructions. This is for the latest version of Borderlands (1.5.0)

I will also be creating written tutorials covering basics of the unreal editor sometime down the road in hopes of getting more people interested and involved with making new content.

Resources

These are the resources you will require to begin your modding.

ZBL patch
Oasis Map Hub
WillowTree

Getting Started

  1. Download all of the resources listed above.

  2. Extract the ZBL_Patch.zip to your Borderlands directory.

  • It should promt you to merge and overwrite files, select yes to all.
  • If you didn’t merge folders you extracted it to the wrong spot. Go back and try again.
  1. Located in the folder you just extracted to:
    If you are running Windows 7 run the file win7_fix.bat
    If you are using Windows XP or Vista (really…?) run the fix.bat

  2. STEAM USERS ONLY
    If you are not using a steam version skip to step 5.
    If you are using steam go to the following directory and delete the file “nvcpl.dll”

    C:\Program Files (x86)\Steam\SteamApps\common\Borderlands\Binaries

  3. Extract the folders “MapSlots” and “Oasis” from Oasis.zip into the following directory.

    …\Borderlands\WillowGame\CookedPC\Maps

  4. Extract WillowTree#.zip anywhere you prefer, I suggest your Borderlands root directory just to keep everything in one place.

  5. Run WillowTree#.exe and click the orb in the top left corner, select open.

  • From here you will have to find your character save location if it is not automatically set there.
    They can be found here:

C:\Users\*******\Documents\my games\borderlands\savedata

  1. Once you have selected a save file the name and level of your character should appear in the bar at the top of WillowTree#, if this is not the character you wanted go back to step 6 and select a different save file.

  2. Once you have the character you want to access modded content click the general info tab.

  • From here under the list on the right hand side “Visited Locations” click New.
  • There will be a location called “Oasis” click it, it should add it to the list.
  • Click the orb in the top left and select save.
  1. You should now be able to find the Oasis in your fast travel locations.

  2. To install custom content you will usually overwrite a “Mapslot” in the “MapSlots” folder.

  • Once you have overwritten a Mapslot file you will head into the game and to Oasis where you will find a bunch of signs with numbers on them, the one to use will be the same number of the mapslot you overwrote.
  1. Sometimes there will be additional packages that come with custom content, these can be placed anywhere within the “CookedPC” folder.
  • Packages contain all of your textures, sounds, definitions, etc.
  1. If you only want to play custom content you can stop here, if you want to access the editor and create your own content read on.

  2. Go to your binaries folder, right click the Borderlands.exe and create a shourtcut.

  • Rename this shortcut to something along the lines of “Editor”
  1. Right click newly made shortcut and select properties.
  • Where it says “Target:” you will see a line of text
  • Wrap the entire target in quotations and add -editor to the end, it should look something like this, but not exactly so do not copy and paste my line below.

“C:\Program Files (x86)\Steam\SteamApps\common\Borderlands\Binaries\Borderlands.exe” -editor

  1. You should now be able to run the editor.

Credits

DrZed - For creating the ZBL Patch making all of this possible.
Amran - For creating the beautiful Oasis Hub.
XanderChaos - For creating WillowTree#
Matt911 - Also for creating WillowTree#


[DLC] The Underdome 2.0
[WIP] Project Sanctuary - New release! Bloodshots!
Help Borderland editor
[WIP] Project Sanctuary - New release! Bloodshots!
(Angry Crux Guy) #2

Yes I know, shame on me for a 191 day (~6 month) necro but could be a common enough question so here goes: If you get a message "Ambiguous package name: Using
‘…CookedPC\WillowGame\CookedPC\DrZedPatch.upk’, not
‘…CookedPC\DrZedPatch.upk’ " is that normal assuming you’re using the steam version of Blands?
Curious since it seems to allow/ignore the error and go to the Borderland’ Unreal Editor.
Oh and this pops up when using the Editor shortcut and regular non editor shortcut.


(Dopefiend) #3

Holy it’s been 6 months since I created this? No worries no shame, that is what this thread is for.

For the error at hand that just means you have two of the same package located somewhere on your computer and that it is telling you which one that the editor is deciding to use since it can only pick one. If you look closely at the directories they will be different.


(Angry Crux Guy) #4

So it should be all right to delete one for example the one it isn’t using? Want to get rid of the pesky (error) message.


(Dopefiend) #5

Yes I would get rid of that one myself.


(Dopefiend) #6

If you need any help with the editor at all please feel free to ask whether it be regarding errors or even how to do things with the editor. I myself and I’m sure others around here are happy to lend a helping hand.


(Angry Crux Guy) #7

Nah, it’s working now. All I have to do now is learn how to pilot UE3 Mark Borderlands >_<


(Dopefiend) #8

If you are starting level development this is an absolute great place to start and is how I began learning the engine. Almost everything should apply to our editor although it is slightly different than vanilla unreal.

http://www.3dbuzz.com/training/view/unreal-development-kit


#10

Hey. I have little a problem with the editor.

I have Borderlands on steam so I deleted the nvcpl.dll like you said. But then the editor didn’t work anymore, so I put the nvcpl.dll back. Now the editor starts, but when I want to open a map, the program crashes. A few months ago, when I first instaled the editor, it worked a few times and since then I had this problem. Did something change since you wrote this Tutorial or is it just something on my pc?


(Dopefiend) #11

Im out of town at the moment so I might not be the biggest help at the moment, but if I were you I would try deleting the temporary files in your documents / my games / borderlands / unpublished location. Just make sure you don’t delete your own custom packages because that is where they are saved to by default. Having too many of these temp files can cause frequent crashes or stop the editor from launching all together. If this doesn’t help I will be back on the weekend to lend a hand.


(Genchaydar77) #12

Hello,

Iam new to the UDK for Borderlands. I habe activated the editor and tried to work with a tutorial series(I have the steam version of BL) I wanted to duplicate a barrel (from the combat shotgun I think) and It didnt functions :confused: The creator of the video told me just to stop with modding because the steam version of the editor is very unstable :confused:
What do you say ?:slight_smile:


(The Gun Smith himself! :D) #13

@genchaydar77
@mr.mcqwark

I’ll just fill in for Dope here. Peeps, don’t try working with the UDK via Steam. It simply doesn’t work as its highly unstable and crashes every minute. That and it corrupts your Borderlands save data. You’ll need a GotY retail edition.


#14

ok now it works again.


(...) #15

Just popping in to say thanks to all for the resources and tuts. Just getting started with this.


(Wwengert312) #17

i cant find the file in the binaries folder, help please?


(Kool Sk8er) #18

when i right click the shortcut, the target directory doesnt show. any ideas on how to fix it?


(barnes3) #19

I take it you mean the editor shortcut ?you made ?
it should look like this “C:\Program Files (x86)\2K Games\Gearbox Software\Borderlands\Binaries\Borderlands.exe” -editor
be careful to have a space after the" and -editor?? !!


(Dopefiend) #20

Sounds like you don’t have an actual shortcut, but an exe. Right click the Borderlands executable and create a shortcut, from that newly created shortcut right click it, properties and you should now see the target directory.


(Franckestanyt) #21

I got a problem, i do the shortcut, but i place later of " -editor and it stay opening steam borderlands, no the editor, please help :frowning:


(Angry Crux Guy) #22

To get the editor (at least for the Steam version) you’ll need to leave the nvcpl.dll file in the binaries directory as well as at shortcut w/the “target” -editor edit. You -need- the nvcpl.dll file intact and in the proper location to access it so if you want to play the game and/or test your creations you’ll need to remove it from the binaries directory (or at least I do on Win10, don’t know about 8.1, 7, etc.)