Ue4 Low Level Fatal Error crash on launch

trying to launch game from Epic Launcher. The Prelaunch/ splash screen appears (before the shader Claptrap load screen) Then it crashes.

Top of the window
“The Ue4-OakGame Game has crashed and will close”

“LowLevelFatalError [File:Unknown] [Line:242]
Device-> CreatePipelineState[Desc, IID_PPV_ARGS(&PSO)) Failed
at t:\OAK-PATCHDIESEL-DIESEL\main\Engine\Source\Runtime\D3D12RH\Private\Windows\WindowsD3D12PipelineState.cpp:725 with error E_Fail …”

then lists the rest. top being Kernelbase.dll, the rest being Borderlands3exe! unknownFunction

I tried to google this but came up short on answers.

DX12 updated, Drivers Updated, Game Uninstalled-Reinstalled and verified through Epic Launcher, even updated the BIOS in case that was the issue.

Windows 10 machine, Ryzen 7 3700 x 8 core, AMD Radeon RX5700 XT

4 Likes

I received the same crash message last night. Cannot launch the game without getting the error. I also restarted, uninstalled/reinstalled BL3, verified through Epic Launcher.

I am also using AMD Radeon RX5700XT.

image

2 Likes

Getting the exact same error. Running from steam myself!

1 Like

are you also running a RX5700 card? I’m wondering if that’s the common thread?

i’ve also put in a ticket at 2K. hopefully can find some answers so we can get back to looting and shooting people in the face.

Update 1:
Support sent me this link https://support.2k.com/hc/en-us/articles/360009266794--PC-General-Troubleshooting-for-2K-Games

(which TLDR: verify your game and update drivers) so now going to send screenshot of crash info and see if we get anywhere else…

Update 2: had me do a clean boot, disabling everything but windows in startup with restarts x2, then verify, then clean boot again along with directions to update drivers (that were already done)
same error code, sent along in the email. (you can certainly try this and see if it works for you)

1 Like

odd - i use linux with steamplay proton-ge and recently just installed the game (the other day)
and for some reason it wasn’t working yesterday and I get the same error code as well.
also using amd cpu
amd ryzen 3750h
rtx 2060

maybe it’s a ryzen thing? idk

Yep I’m on a 5700 XT OC Gaming from Gigabyte and I have been getting my butt kicked the last week. To be honest I’m really hoping it’s AMD I have spent countless hours wiping windows etc this past week I’m over looking for solutions.

Did that work for you?? I’m still dead in the water.

Negative good buddy.
Even did the windows update in hopes something might be patched there.

No email replies from them after I did the clean boot cycles and replied to them that it did nothing, along with a fresh screenshot of the error box, in case any of the dll codes had changed.

Sorry I have no good news for you folks :confused:

I swapped graphics cards to see if that made a difference and I’m no longer having the issue. I’m now using nVidia RTX 2060 SUPER. Seems like the AMD Radeon RX5700 XT is the culprit. Best of luck resolving your issue.

If I had one to swap would have done so. :confused:

Today I first got 2 crashes in game saying memory access violation… Rebooted and now I’m getting the same thing at the first splash screen.fatal

Using a GTX1080 with 451.67 drivers. Steam version.

…Did a little more digging and this crash might have something to do with Directx 12 and the fix might be to change the game’s ini settings to use Directx 11. (Kind of a no duh moment looking back at the error window… “\Engine\Source\Runtime\ D3D12 RH\Private\Windows\Windows D3D12 PipelineState.cpp:725”) You can change the setting in the GameUserSetting.ini file located at C:\Users\Administrator\Documents\My Games\Borderlands 3\Saved\Config\WindowsNoEditor

Look for “PreferredGraphicsAPI” and change it from DX12 to DX11, don’t forget to save.

…Seems to have worked. But running it in DX11 I had some major frame skipping… I feel that DX12 might still need to be repaired. I’ve found some information that might help to fix it. It requires downloading Windows Media Creation Tool from Microsoft and downloading Windows 10 ISO and running the setup.exe from there and choosing the repair option.

…So I repaired Windows and tried Borderlands 3 in DX12 again, no error popped up but the game would never load past the splash screen. So I deleted everything located in the C:\Users\Administrator\Documents\My Games\Borderlands 3\Saved (copying the SaveGames folder to another folder) and the game started right up.

Something in the config folder had to have been corrupted and deleting everything in that folder forced the game to rebuild those files and played for about an hour with no issues, seems to have worked… Hope my journey can help others.

5 Likes

yeah, Official support just got to me this morning telling me to do so…

computer just Greened out with a tone and shut down. so that was a fun all new error.

also running the game Remnant which is also a UE4 game I think caused it to crash out so I think its something in conflict between the engine and the card.

update 1: underclocking the card in settings along with the rollback to DX11 seemed to get me stable enough to launch the game and play through Carnivora and the Agonizer 5000; but as soon as I exited the software reset to default…again. (been a constant struggle to save settings)

also added more fans to case to increase flow as the current heatwave might be effecting things.

I have an Asrock Challenger version of the 5700 xt, that may be relevant to getting to the bottom of things as well.

Will report any updates as they come along.

1 Like

hey guys sent in a ticket to 2k but verifying game files actually fixed this error for me. Got past splash screen and everything… Try right clicking game on steam and verifying local game files and it should find atleast 1 file missing. Guessing it has to do with system detection and engine

1 Like

glad you got past the hurdle.

downtuning the card + DX11 rollback seems to have stabilized it. got to play a good long while without a crash. will try to get spousal person to get a screenshot of the new settings (it’s actually been their PC) to see if replication works for others.

1 Like

I just did a fresh install of Windows, Steam, and Borderlands 3. It is still crashing on me. Ryzen 1700, Rx560, 16gb mem, 1tb sad. Same crash as before, when I was using an hdd.! 20200830_165836|484x445

there is a manual driver update to 20.8.2 for the rx series released on the 11th of August. tried that one?

If I could hug you, I would. I was suuuper frustrated with this, but deleting the folder worked for me! Also, thank you for putting the path, I had seen somewhere else that had the tip about editing the file, but they didn’t put a path, which made it useless for me. Back to gaming!

2 Likes

Huzzah’s and Hugs all over! Back to shooting people in the face, IN THE FAAAAAAACE!

A near-identical error message also appears if you run certain mods, mods for other games mind you, not for BL3. I for example use mods for the Final Fantasy X/X-2 Remaster (would otherwise not even boot) and Reshade for multiple games and somehow some mods can access UE4 games at times or rather it seems as if the game picks up the mod as the mods I use aren’t even programmed to access more than 1 specific game (except Reshade, but that isn’t causing any trouble).

I don’t know why that is, but that can lead to a DX12 crash or an “unauthorized access” crash.