Where did my FPS go?

I just bought a high end gaming pc for college, this was the only game I was looking forward to playing. I dropped 2 grand on an IbuyPower Chimera Gaming Pc.

Processor Intel® Core™ i7-9750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
Installed Physical Memory (RAM) 16.0 GB
Name NVIDIA GeForce RTX 2070 with Max-Q Design

I thought I would have more than decent hardware to run this game, but it runs around 10 fps on low settings. I haven’t found a way to allocate more ram if that’s even possible. Anyone else having sort of the same problems. Sorry I’m not sure what specs to list, if someone were to ask I’d be able to supply.

1 Like

The PC optimization is pretty awful right now, something is clearly wrong on their end for some of the high-end PC users to have this many issues. Hoping they are aware and try to fix it ASAP.

1 Like

I sure hope that CPU overclocks :s

idk how you are getting 10fps though, I feel like that cpu would bottleneck your gpu hard though if you arent OCing it.

I’m not sure how to overclock or even how to go about that. Its a laptop, not sure if that matters

Would be in bios when you start up but idk about laptops or that cpu sadly.

Should I just give it time, The opening cut scene ran at around 5 fps on low settings. I’m not sure where to even go from here, my pc runs everything else fine. Would internet be an issue, im on college internet.

When you say runs everything fine what do you mean?


For example, I’m on the menu getting 10 fps

is your fps capped at in settings?

I’m sorry, in game or out of game settings.

Ingame


I appreciate you helping me

Would maybe my intel i7 be doing graphics instead of my nvidea card, i had the problem on some other games.

Very possible. Go in nvidia control panel and add the game to profiles in 3d settings and lock it to your gpu

Does this matter?

nah just do the cuda - gpu part and lock it to gpu. Other settings will just change with what you set ingame. Also set rendered frames to 1 at bottom.

Sorry explain?

all it has is my checkmarked gpu

So click the dropdown and click your main GPU.