Why do I have PhysX on an AMD card?

What the title says, really.

I have an MSI Radeon R9 280X, and until recently I couldn’t run PhysX. I’m certainly not complaining - although they heat up the CPU a bit - but when did this happen? Also, is it a game patch/fix or an update from the maker of my GPU?

I don’t follow tech news, hence my ignorance, but I’m surprised I missed this.
Any and all info welcome!

Becaus on PC this work also on AMD cards :0D
I don’t know why they not make this on PS4?

Yeees, but…with my GPU it didn’t work before. The option was greyed out.
Thus I was wondering about updates and the like.

Its running of the CPU. Go to Caustic Caverns, set Physx to High and watch your PC die as you murder the Crystalisks!

Hm, well that’s a thought. I’'ll send you the bill, then, shall I :stuck_out_tongue: ?

your gpu should handle it just fine. everything maxed out barely taxes my comp.

Yep, it’s no problem. Sadly, I think half of the areas in the game don’t really benefit from PhysX, it’s a bit too cluttered visually for my taste. I tend to leave it on ‘low’ (which, as I understand it, equates to ‘off’) or medium, depending on what I’m doing that session.