Windows 7 SDK for RtH30 and EiB: Success!


#6

@Rendroc, Thank You very much for this posted solution for SDK running!

It looks like, that the SDK tool is working even on my Windows Vista Home Premium 32-Bit OS (with Service Pack 2). I just replaced the default Core.dll file found in my BiA: RtH30 and EiB System folder with the one from the SDK fix and then i simply run the SDK installer.

The UnrealED.exe works now in both RtH30 and EiB. The SDK installation didn’t freeze anymore :slight_smile: .

Please, give my regards to Warrior250 at ModDB. :wink:


(GASMASK INTENSIFIES) #7

Hey guys, This is the Legit Warrior250 xD… just made my profile here in the new GB forums, by the way, im glad that my simple help for Rendroc can also be a help for other more, good luck on modding!


(LeYuno) #8

If it’s ok I’d like to add this solution to the unofficial sdk wiki. I think other people might like this information.

edit: i kinda went ahead and added this information to the following page: http://modelspecialist.be/biasdk/index.php?title=Getting_ready_to_mod


(GASMASK INTENSIFIES) #9

Im not credited :frowning: … but it doesn’t matter, atleast it helps people :slight_smile:


(LeYuno) #10

you are now :wink: thanks for the help on this, it’s an awesome game to mod or map in and this will greatly enhance the chances of people making new stuff for BIA.


(GASMASK INTENSIFIES) #11

Thanks, but i shouldn’t take all the credits since Rendroc did some things for me as well and this is just my way to repay his help, and glad to hear that :smiley: let’s get the old series back in it’s feet again :slight_smile:


#12

I was able to get the compiler working.

I updated the downloads with a new script and added some instructions to the original post.


#13

Thanks!!


(Max) #14

Hey Rendroc,

I admire all your hard work, you created a whole new level of replayability for one of the most memorable games from my childhood and I thank you. When I saw this post I was hoping to finally be able to install the SDK and do some modding of my own, however I can’t get the damn thing to install. I followed your guide step by step but no matter what I try I get the same message every time: “Please Install BiA Earned in Blood before attempting to run this installer”…

Although I still have the CD I couldn’t use it on my system or starforce would wreck my windows, so I bought the game on steam instead. Now I can imagine the SDK installer not working because of steam but I have no idea what exactly causes this problem.

I hope you or maybe someone else with more knowledge than me on the subject could help me get this darn thing installed so I can finally do some modding of my own.

Cheers


(GASMASK INTENSIFIES) #15

Hey Lukas, it has to do with the registry files… mostly the one that leads to your BiA EiB Registry.

Warrior250


#16

Yes, I think that might be it. Check your registry to see if BrothersInArmsEiB is in it. If not, you can add it yourself. In my SDK tool there should be a file bia_fix.reg. Open it with notepad and make sure it has the correct path to your BiA game. Then install the registry. After that the SDK should be able to install.


(Max) #17

Thanks for the suggestions guys, but my efforts were sadly in vain.
Here’s the situation:
My game is a steam install and I installed rendroc’s warzone&realgunsounds over it. I dropped the files from eib_sdk_w7.zip into the system folder after I made a backup.
I then ran bia_fix.reg after I confirmed the directory was correct with notepad (c:\program files (x86)\steam\steamapps\common\brothers in arms earned in blood"). But after I did this I noticed that the key under [HKEY_LOCAL_MACHINE\SOFTWARE\Ubisoft\Gearbox Software\BrothersInArmsEiB] now says BRPCRC1.1 while my original key said EIBCRC1.0. Does this mean steam provides only the 1.0 version of the game? I already suspected this because I don’t have the Across the Marsh skirmish mission. I tried updating it to 1.3 a while back but I wasn’t able to do so. Can someone confirm they were able to install the SDK on the steam version? At least then I’d know I’m not wasting my time here. :confused:

Ps: I am also unable to start the game with the new system files. I have to switch over to my backup of the system folder or else I get this message while trying to start the game: Can’t find file for package ‘core’.


#18

Hmmm, I’m not sure. I have the steam version too, which should be the latest and patched already. The version in the registry isn’t important, only the directory which is used to help the SDK installer find the BiA files.

I have experienced the same problems as you, but I wrote that guide to try to fix all of it. If you followed everything in the correct order, then I’m not sure what went wrong. Are you saying you still can’t install the SDK?


(GASMASK INTENSIFIES) #19

I Took a look at my Registry files, same goes for me; my Road to hill 30 Reg says BIAPCRC1.0 (Retail probably) while my Earned in blood says EIBPCRC1.0

My copy is retail mostly…

But a while back i experienced not being able to install SDK as well, but what i did is to make a new registry entry and click on a patch, which fixed everything… i guess i must be lucky with that part, but hey… it’s worth the try.

Here’s what is shown in my EiB Registry by the way: Do not mind the Folder, it’s where i installed my copy.


(Max) #20

Yep, I tried everything to get it to work but the SDK installer just doesn’t work. Today I even removed everything and installed the game again, then with my clean install I followed your instructions and it still doesn’t work.

I’m sure you’re aware of this but Steam EIB adds keys under: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\UBISOFT
whereas your registry fix adds keys under: HKEY_LOCAL_MACHINE\SOFTWARE\Ubisoft
Now even if these two locations contain the exact same entries/keys whatever the SDK installer still tells me I need to install EIB first…


(Max) #21

I’m not sure what you mean by “click on a patch”? Could you maybe elaborate on how you got it to work?


#22

That’s true, I’m glad you noticed that. Perhaps it was not the registry, or maybe that’s only a part of it. I did get it working on Steam by trying a lot of stuff and maybe I forgot a step.

See if you can download and install the latest patch from here, I think it’s v1.03:

Steam should have the latest patch already but perhaps they missed a file or something.

I’m running out of ideas. The last thing to do cross check our installations, but that is tedious and might still not get the answer for us.


(mgs48888) #23

I’m not sure steam has the latest version as I remember 2 additional levels for skirmish that aren’t there in the steam version. My 2 cents.


(Max) #24

Sooo, it has been quite a while but it may be useful to post my succes here!

Today I tried, once again, to get the sdk working.
No matter what I tried, the sdk installer wouldn’t work, so I began searching for a way around and I found it!
I extracted the files from the sdk exe with 7-zip then moved all the files into my “earned in blood / system” folder.
I then ran win7fix.bat (not sure if I needed to), after which I tried to ran UnrealED.exe and to my big surprise IT OPENED UP THE SDK!!
In case I mess up a map or some files I have made an earned in blood folder for the editor (in which I can mess with the maps etc.) and a folder with which I play the game.

Amazing really, I have been trying to get this thing to work for so long…
Now I just have to learn how to use the SDK and how to script so I can edit/make mutators…

I was hoping I could find an easy way to make the flak 88/pak36 usable for my squad but this seems like a lot of work.
I also tried changing the m10 tank model in “run of the mill” to a panzer IV so I could use it with rendroc’s “the germans” mutator but this led to a weird situation where I could command the panzer IV to move and fire/assault enemies but it was marked as an enemy and it would fire its machine gun on me and my squad if we were to walk in front of it. :joy:

Just thought I’d let you guys know!


(Max) #25

You are right btw, the additional levels don’t exist in the steam version. I also can’t patch it whether I try it with 1.01, 1.02 or 1.03.